Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-20-2014, 06:16 PM   #1
CHC
Junior Member
 
Join Date: Aug 2014
Posts: 2
Atwood GC10A-4E Water Heater troubles

I have an Atwood GC10A-4E water heater in my 2006 Fleetwood Bounder 35E it works fine on AC. Will light on gas but shuts off after a few seconds.

Wondering if I need to replace the heater control module circuit board #93851. Hesitant to buy one as it does light the propane but shuts right off after. Kinda making me crazy.

Any help would be much appreciated
__________________

__________________
CHC is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-20-2014, 07:34 PM   #2
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 14,721
Welcome to iRV2.

If this control is the one I'm thinking of , it uses the igniter wire as a temp sensor wire after the spark cycle. So it is very important that the spark probe be in the proper position over the flame, clean, tight connections and the flame be hot instantly.
I'd say take the burner tube off and the igniter tips , clean both parts, install and re-try.
I'll double check the manual for any other tips on your problem. and re-post.

EDIT: I have seen flame issues with these heaters caused by dripping water from the pressure relief valve so when you have the burner tube off , remove and clean the brass jet from the propane control, clean with compressed air and brake parts spray cleaner, a partially plugged jet will give low flame and shut the heater down.
__________________

__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 08-21-2014, 01:56 PM   #3
CHC
Junior Member
 
Join Date: Aug 2014
Posts: 2
Atwood GC10A-4E Water Heater troubles

Thanks Skip, as I mentioned the burner lights good blue flame goes out after a few seconds I did pull the electrode and checked the 1/8 inch clearance was clean too. Hopefully you find something else in the manual.

Thanks Again
__________________
CHC is offline   Reply With Quote
Old 08-21-2014, 06:19 PM   #4
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 14,721
In the " Files " drop box, blue bar under your welcome message, there is an Atwood water heater manual available for download, if you don't have one.
May come down to phoning local RV repair shops to see if they can bench test the controller if you bring it in.
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Reply

Tags
atwood, heater, water, water heater



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Antifreeze in Suburban Water Heater OK? n5pht RV Systems & Appliances 2 07-14-2014 05:43 AM
Atwood g6a-8e water heater question gazingm42 Travel Trailer Discussion 2 07-10-2014 08:01 PM
Water Heater problems Sitkadoc Tiffin Motorhomes Owners Forum 8 05-13-2014 09:02 AM
Atwood g6a-8e water heater Momma Cella RV Systems & Appliances 1 04-14-2014 07:47 PM
Atwood & Suburban water heaters & Furnace "007" RV Systems & Appliances 1 08-07-2010 09:37 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:01 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.