RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-06-2017, 06:20 AM   #1
Senior Member
 
countrypair's Avatar
 
Join Date: Sep 2010
Posts: 295
Domestic 15K AC Problem

5th wheel been in storage for 4 months. Opened up & started AC units (in FL). Both seemed to be running fine. However, noticed 15K unit started not blowing cool air & fan continued to run on high & wouldn't shut off unless I raised the temp setting. It sounds like the compressor starts to run, but doesn't blow cool air. My other unit cycles normal. Any thoughts on problem? Unit is only 6 months old.
__________________

__________________
2017 Grand Design Reflection 26RL
countrypair is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-06-2017, 06:31 AM   #2
Senior Member
 
Join Date: May 2017
Posts: 162
Since you are in Florida maybe you froze it up from the humidity? I would let it sit an hour or so then try again.
__________________

drivintin is offline   Reply With Quote
Old 10-08-2017, 05:08 AM   #3
Senior Member
 
countrypair's Avatar
 
Join Date: Sep 2010
Posts: 295
I Had RV Tech check the unit. Low charge! Unit only 11 months old & only used about 2 months & it fails. I guess Dometic is going the same way as Norcold. The unit has to be replaced.
__________________
2017 Grand Design Reflection 26RL
countrypair is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Domestic 8700 Series Master Flush Toilet Problem (2016 DS) Capt. Kirk Newmar Owner's Forum 8 08-06-2017 10:45 AM
Domestic refrigerator problem njbill RV Systems & Appliances 7 07-28-2017 09:40 PM
2014 Ventana Domestic Hot Water Problem quadder Newmar Owner's Forum 2 06-13-2016 10:25 PM
Domestic Fridge Problem patncris RV Systems & Appliances 10 01-18-2015 06:33 AM
13.5k btu or 15k btu air condtioning PClayton Travel Trailer Discussion 2 07-19-2005 08:17 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:32 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.