RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-30-2005, 11:09 AM   #1
Senior Member
 
Ken Lenger's Avatar
 
Join Date: Jul 2001
Location: Tucson AZ
Posts: 393
After two years (since new) of trying to figure out why my Onan 3600LP generator would occasionally shut down, I finally figured it out.

"Way Back" machine to spring of 2002: Within a few months after installing my generator, I began having problems with it shutting down, usually after the A/C would cycle off. I did some checking with the on-board diagnostics, and determined that the shut-down was caused by an over-frequency condition caused by excessive engine RPM's. I bought a digital freq / voltage meter from CW and verified that the generator would shut down when the freq. exceeded 65 Hz. Engine speed is controlled by a mechanical governor, so obviously, the governor was not working correctly.

Forward several months: I took the camper to a local RV dealer (Beaudry RV in Tucson) who is an Onan authorized service center. At first they could not duplicate the problem, and said nothing was wrong with it. After showing them the problem, they made some adjustments to the governor, broke my entry steps, and charged me $80 because Onan only covers adjustments for 90 days under warranty. They comp'd me the $80 for breaking the steps, but I continued to have generator shut-down problems.

Forward some more: Next, I bought a service manual, and studied up on how the governor works. Since the problem was not consistent, I assumed that the governor mechanism must be binding due to some friction in the mechanism. Note: I have now lived with this problem for over 2 years (out of warranty now).

Forward to Last night: I got serious with it and messed around with the governor while the set was running and could see no sign of binding, but I did notice that if I forced the throttle to minimum speed (by over-riding the governor), the freq. would go no lower than 60 Hz with no load. I looked in the service manual for info on this, and noticed that the idle speed (by over-riding the governor) should yield a freq. of 40 Hz. A simple adjustment of the idle screw to lower the idle speed, and .... WOW, IT WORKS. Now the range of throttle speed control is sufficient for the governor to maintain engine speed within the specs (58 - 62 Hz). I am so jazzed about this, I guess I will quit looking at how to install a Honda EU-3000.

See http://www.klenger.net/arctic-fox/ge...ion/index.html for details of the installation.

Sorry for the long post.
__________________

__________________
2014 Winnebago Adventurer 32H
2011 Honda Fit Toad
http://www.klenger.net/32h-adventurer.html
Ken Lenger is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-30-2005, 11:09 AM   #2
Senior Member
 
Ken Lenger's Avatar
 
Join Date: Jul 2001
Location: Tucson AZ
Posts: 393
After two years (since new) of trying to figure out why my Onan 3600LP generator would occasionally shut down, I finally figured it out.

"Way Back" machine to spring of 2002: Within a few months after installing my generator, I began having problems with it shutting down, usually after the A/C would cycle off. I did some checking with the on-board diagnostics, and determined that the shut-down was caused by an over-frequency condition caused by excessive engine RPM's. I bought a digital freq / voltage meter from CW and verified that the generator would shut down when the freq. exceeded 65 Hz. Engine speed is controlled by a mechanical governor, so obviously, the governor was not working correctly.

Forward several months: I took the camper to a local RV dealer (Beaudry RV in Tucson) who is an Onan authorized service center. At first they could not duplicate the problem, and said nothing was wrong with it. After showing them the problem, they made some adjustments to the governor, broke my entry steps, and charged me $80 because Onan only covers adjustments for 90 days under warranty. They comp'd me the $80 for breaking the steps, but I continued to have generator shut-down problems.

Forward some more: Next, I bought a service manual, and studied up on how the governor works. Since the problem was not consistent, I assumed that the governor mechanism must be binding due to some friction in the mechanism. Note: I have now lived with this problem for over 2 years (out of warranty now).

Forward to Last night: I got serious with it and messed around with the governor while the set was running and could see no sign of binding, but I did notice that if I forced the throttle to minimum speed (by over-riding the governor), the freq. would go no lower than 60 Hz with no load. I looked in the service manual for info on this, and noticed that the idle speed (by over-riding the governor) should yield a freq. of 40 Hz. A simple adjustment of the idle screw to lower the idle speed, and .... WOW, IT WORKS. Now the range of throttle speed control is sufficient for the governor to maintain engine speed within the specs (58 - 62 Hz). I am so jazzed about this, I guess I will quit looking at how to install a Honda EU-3000.

See http://www.klenger.net/arctic-fox/ge...ion/index.html for details of the installation.

Sorry for the long post.
__________________

__________________
2014 Winnebago Adventurer 32H
2011 Honda Fit Toad
http://www.klenger.net/32h-adventurer.html
Ken Lenger is offline   Reply With Quote
Old 03-30-2005, 12:37 PM   #3
Senior Member
 
FatDog's Avatar
 
Join Date: May 2001
Location: NV
Posts: 2,065
Send a message via MSN to FatDog
nifty tool first of all

i am shy in the electrical knowledge dept., but.. you are saying
the Onan would power off because once the AC turned off, the onan would have a brief temporary RPM spike??
so if your idle speed screw on the Onan had been set too high all this time and when the Onan spiked briefly it if would raise the R's to an unacceptable level. You in essence then lower the idle speed to where it should have been (yielding 40Hz. freq.) and now if/when the R's jump they are still in 58-62 Hz range. ?
It sounds like the governor not only was the idle set too high, but the governor was allowing RPM spikes ??
MIke
__________________
F350 PSD 4x4 SRW, BanksBrake, FOX res shocks, MagHytec, DP tuner, JohnWood tranny;
ChrisCraft Launch VP8.1 ;
3 hound dogs
FatDog is offline   Reply With Quote
Old 03-30-2005, 02:36 PM   #4
Senior Member
 
Ken Lenger's Avatar
 
Join Date: Jul 2001
Location: Tucson AZ
Posts: 393
The governor holds the speed between 62 Hz (no load) and 58 Hz (Full load). The 40 Hz idle setting is accomplished by forcing the throttle to the idle stop by over-riding the governor.

The problem I was having is that the idle speed was so close to the desired operating speed (60 Hz) that the governor could not throttle back anymore. The problem would happen when the A/C cycled off, reducing the load on the generator and the RPM's would drift up. Sometimes it would happen if I started the generator and ran it with no load applied. Note that the over-speed condition was not a brief spike, but the speed would drift up over a period of 30 seconds - 2 minutes or so. Once the freq. hit 65 Hz, the generator control board would shut it down.

Complete setup instructions can be seen in the service manual on pages 8-6, 8-7, and 8-16 at http://www.klenger.net/arctic-fox/ge...ice-manual.pdf
__________________
2014 Winnebago Adventurer 32H
2011 Honda Fit Toad
http://www.klenger.net/32h-adventurer.html
Ken Lenger is offline   Reply With Quote
Old 03-31-2005, 04:37 AM   #5
Moderator Emeritus
 
Joe-K's Avatar


 
Tiffin Owners Club
Pond Piggies Club
Join Date: Mar 2000
Location: Butler, PA
Posts: 1,830
Hi Ken,

Nice catch on the generator. Persistance pays off I suppose. Thinking about the situation, I can understand how the unit would overspeed with the idle screw being set so close to the 60hz speed.
__________________
Joe & Shelly, Justin, Tyler, Alyssa | Butler PA
2008 Tiffin Allegro Bus 43QRP|Cummins 425|Honda CRV
Joe-K is offline   Reply With Quote
Old 04-04-2005, 07:25 AM   #6
Junior Member
 
DSDPforRacin''s Avatar
 
Join Date: Sep 2003
Location: Houston, Texas USA
Posts: 12
We are having the same problem with our 7.5 Onan. They replaced the governor last week and the minute we drove off and got 30 miles down the road the gen cut off. It still will not start even cold. Took it back today to Cummins Southern Plains in Houston. They still don't know what to do. Philis
__________________
Talladaga Oct '04 http://photos.yahoo.com/hookedoncrayola
DSDPforRacin' is offline   Reply With Quote
Old 04-20-2005, 02:14 PM   #7
Junior Member
 
Primetime's Avatar
 
Join Date: Nov 2002
Posts: 4
Ken, I've checked out your lpg genset install as I am doing one soon with an Onan 4000 Emerald Plus, but couldn't determine how you connected to the lpg cylinder. I'm guessing your gen-set came with it's own gas regulator, so how did you connect to lpg,(1)directly to the full pressure of the gas cylinder,(2) install a high pressure reg. in the system, or(3)just tie in behind the trailer's regulators? Having two regulators set @ 11" WC in line doesn't sound plausible to me. Any insight appreciated!
__________________
David & Kathy

'98 SunRidge
Primetime is offline   Reply With Quote
Old 04-20-2005, 05:22 PM   #8
Senior Member
 
Ken Lenger's Avatar
 
Join Date: Jul 2001
Location: Tucson AZ
Posts: 393
The Onan 3600 LP is designed to run on low pressure vapor LP. I ordered a generator prep package when I spec'd the camper, and part of the package is a "T" in the low pressure LP line just below the tanks. That's were I tied it in. Onan also makes some LP generators that are designed for high pressure liquid LP.
__________________
2014 Winnebago Adventurer 32H
2011 Honda Fit Toad
http://www.klenger.net/32h-adventurer.html
Ken Lenger is offline   Reply With Quote
Old 04-20-2005, 06:25 PM   #9
Junior Member
 
Primetime's Avatar
 
Join Date: Nov 2002
Posts: 4
Sorry Ken, I didn't specify my genset as being the vapor lpg type, and rated to operate with lpg pressure at 9">11" WC. It has it's own regulator and 12VDC powered lpg shut-off solenoid valve. My concern is running it with two in-line regulators, one at the gas cylinder and one at the genset, both at 11" WC. Is that how yours is set up? All I would need to install it on the trailer's regulated lpg system, would be to remove a 1/2" pipe cap on the gas line run, no "T" required. That's if it can be operated with the two in-line regulators. It sounds way too easy! BTW, very nice install on your rig, I hope mine turns out that well!
__________________

__________________
David & Kathy

'98 SunRidge
Primetime is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Finally, all warrenty bugs fixed!!!!!!!!! AKBrick Monaco Owner's Forum 8 08-26-2008 06:37 AM
Basement AC finally fixed!!! Lucchese1 Winnebago Industries Owner's Forum 27 07-01-2008 01:42 PM
Cummins shut down due to an electrical problem chirohand Monaco Owner's Forum 11 01-03-2008 04:53 PM
onan 5500 shut down after 20 minutes of A/C peter griffin Winnebago Industries Owner's Forum 7 09-10-2007 02:32 PM
refrigerator problem - FIXED! FleetMan Winnebago Industries Owner's Forum 2 09-07-2007 07:01 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:55 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×