RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-23-2019, 11:29 AM   #1
Junior Member
 
Join Date: Oct 2016
Posts: 1
Generator/battery problems

I can't put a finger on what the problem really is so here is what I have
I have a Thor Palazzo 36.? MH diesel pusher with a QD6000 onan generator with a Magnum inverter/converter and a magnum panel that gives me the battery readout and setting the AGS along with the other battery information. When running the generator all is fine my readout says Im floating a charge at 13.4+22A I have my washer and dryer running and a light on plus my residential refrigerator and a microwave clock is set all plugins work, now if I shut off the generator as well as my dryer and washer and sit with just plugin and refrigerator running I will plummet to power failure red light on the panel will come on and it will say low battery. When I try to restart the generator I will have to start the MH wait for about 5 minutes and raise the hood to start the generator outside. So what can be wrong?

I also can't use the AGS because it would start with low battery I do have it set correctly
__________________

Sandyfou is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-23-2019, 11:47 AM   #2
Senior Member
 
palehorse89's Avatar
 
Newmar Owners Club
Join Date: Oct 2009
Posts: 8,824
Sounds like time to have the batteries load tested .......
__________________

__________________
2000 Newmar MADP 4060, 350ISC, Spartan MM, IFS 2011 Jeep JK, M&G Braking, 2014 MTI 27' Hog Hauler, Wireless brake control, 2006Ultra & 1989 Springer
palehorse89 is offline   Reply With Quote
Old 09-23-2019, 12:25 PM   #3
Senior Member
 
Join Date: Jul 2014
Posts: 19,134
Agree, batteries sound very weak, if dropping that fast.

Runnning the main engine throws a surface charge in them.

Check the water, if flooded batteries ?
twinboat is online now   Reply With Quote
Old 09-24-2019, 09:43 AM   #4
Senior Member/RVM #90
 
MSHappyCampers's Avatar


 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 38,948
Hi ! Welcome to IRV2! We're sure glad you joined the gang!

I agree with others that you probably have bad batteries!

Good luck, happy trails, and God bless!
__________________
Joe & Annette

2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is offline   Reply With Quote
Old 09-24-2019, 08:22 PM   #5
Senior Member
 
palehorse89's Avatar
 
Newmar Owners Club
Join Date: Oct 2009
Posts: 8,824
Quote:
Originally Posted by MSHappyCampers View Post
Hi ! Welcome to IRV2! We're sure glad you joined the gang!

I agree with others that you probably have bad batteries!

Good luck, happy trails, and God bless!
__________________
2000 Newmar MADP 4060, 350ISC, Spartan MM, IFS 2011 Jeep JK, M&G Braking, 2014 MTI 27' Hog Hauler, Wireless brake control, 2006Ultra & 1989 Springer
palehorse89 is offline   Reply With Quote
Reply

Tags
battery, ems, generator, problem, problems



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dry camp battery charging- Generator direct / Through RV / Battery Charger? Smithers Travel Trailer Discussion 7 06-15-2016 10:13 AM
Battery Problems/Battery Test In Situ? jrpend Winnebago Industries Owner's Forum 10 04-26-2016 02:42 PM
Dealers for Palazzo Problems & Thor Slide Problems "007" Thor Industries Owner's Forum 29 11-10-2015 05:29 AM
A/C Problems with heavy condensation problems Help Please!! Tevans Newmar Owner's Forum 6 06-21-2015 08:26 AM
Leaking problems with Hybrid anyone else have problems? Barrie Expandables, Hybrids, & Lightweights Discussion 2 11-20-2005 08:08 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:58 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×