RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-29-2014, 06:25 PM   #1
Senior Member
 
vsheetz's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Jun 2012
Location: SoCal
Posts: 13,668
Generator was running fine, stopped, will not start...

Generator running fine for about three hours. Then just quit. When trying to restart, it turns over, appears to try to start, then quits. Blinking code 32 (not cranking fast enough...).

On an 5500 Gold, 789 hours.
Oil level is full.
Gas tank is 3/4 full.
Battery connections are tight (code 32 suggestion), and cranking speed appears good and it tries to start...

Oil, oil and air filters maybe 6 months and a few dozen hours ago. Don't know if fuel filter has ever been changed.

Suggestion?
__________________

__________________
Vince and Susan
2011 Tiffin Phaeton 40QTH (Cummins ISC/Freightliner)
Flat towing a modified 2005 Jeep (Rubicon Wrangler)
Previously a 2002 Fleetwood Pace Arrow 37A and a 1995 Safari Trek 2830.
vsheetz is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-29-2014, 06:56 PM   #2
Senior Member
 
trackman's Avatar
 
Join Date: Oct 2011
Posts: 1,136
Check the ground at the gen also. Onan is notorious for loose ground due to vibration
__________________

trackman is offline   Reply With Quote
Old 05-29-2014, 09:22 PM   #3
Senior Member
 
Papa_Jim's Avatar
 
Outdoors RV Owners Club
Join Date: Oct 2009
Location: Manitoba,Canada
Posts: 2,722
Same thing happened to our 6.5kw Onan generator. Turned out the engine control board had failed.

Got a new one from:

A.S.A.P.

Then it started and ran again.

Jim
__________________
2016 Creekside 23RKS
'14 Ram 1500 EcoDiesel
2012 Ram 2500 Laramie 4X4 Cummins 6.7L
Canada, eh?
Papa_Jim is offline   Reply With Quote
Old 05-29-2014, 09:53 PM   #4
Senior Member
 
vsheetz's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Jun 2012
Location: SoCal
Posts: 13,668
Quote:
Originally Posted by trackman View Post
Check the ground at the gen also. Onan is notorious for loose ground due to vibration

Checked grounds. Removed, buffed, and replaced. No joy.
__________________
Vince and Susan
2011 Tiffin Phaeton 40QTH (Cummins ISC/Freightliner)
Flat towing a modified 2005 Jeep (Rubicon Wrangler)
Previously a 2002 Fleetwood Pace Arrow 37A and a 1995 Safari Trek 2830.
vsheetz is offline   Reply With Quote
Old 05-29-2014, 09:57 PM   #5
Senior Member
 
vsheetz's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Jun 2012
Location: SoCal
Posts: 13,668
Quote:
Originally Posted by Papa_Jim View Post
Same thing happened to our 6.5kw Onan generator. Turned out the engine control board had failed.

Got a new one from:

A.S.A.P.

Then it started and ran again.

Jim

Reading and thinking the same. The generator actually does start, runs for a couple seconds, stops.

Pulled the cover off the box with the start switch and circuit breakers, thinking the control board was there, but it's not. Can't find it or a picture online showing where it's located...
__________________
Vince and Susan
2011 Tiffin Phaeton 40QTH (Cummins ISC/Freightliner)
Flat towing a modified 2005 Jeep (Rubicon Wrangler)
Previously a 2002 Fleetwood Pace Arrow 37A and a 1995 Safari Trek 2830.
vsheetz is offline   Reply With Quote
Old 05-30-2014, 06:01 AM   #6
Senior Member
 
94-Newmar's Avatar
 
Join Date: Nov 2009
Posts: 2,043
Post your exact model number. It is highly doubtful the control board is the problem on a 32 error. Speed sense faults can be tricky and can be a result of many different things. If yours is an HG series, in most cases a 32 error is either a drive belt failure or the drive belt tensioner which has become oxidized/corroded and can no longer maintain tension on the drive belt. I can guide you to inspecting the drive assembly, brush assembly/slip rings and windings, all of which can be done, depending upon model, without removing the genset from the coach. Repairing any of the above with exception of the brushes/slip rings would require removal of the genset to repair.
__________________
94-Newmar Kountry Star 40-KSDP
Spartan/Cummins 8.3C-300HP/Allison 3060 WTEC-II/25yr RV Tech RVIA Certified/Onan-Cummins Certified
94-Newmar is offline   Reply With Quote
Old 05-30-2014, 08:34 AM   #7
Senior Member
 
wa8yxm's Avatar
 
Damon Owners Club
Workhorse Chassis Owner
Join Date: Mar 2009
Posts: 24,022
Same thing happened to my next site neighbor in 2007 in Quartsite,,, Generator needed to be refurbished (Brushes bad) in their case.. ONAN generators are like Yogi, smarter than the average bear.. They have the ability to check for output, and if the generator is not working, why waste gas running the engine? So they shut off, and flash 32. (They assume the reason for no output is not running fast enough) alas, they are not all that smart.

Bottom line: There are many conditions that can flash a 32

Thankfully for the folks beside me... They were parked next to the only 30 amp outlets in that part of the desert.. ... Yup.. I have 30 amp daisy chain outlets on my rig. Part of my house upgade from back in the S&B days. (I put in 3 30 amp outlets, (one 4 wire, two TT-30)
__________________
Home is where I park it!
wa8yxm is offline   Reply With Quote
Old 05-30-2014, 12:22 PM   #8
Senior Member
 
D Lindy's Avatar
 
Winnebago Owners Club
Join Date: Aug 2013
Posts: 1,636
Starts, runs a couple of seconds then dies, I'd change the fuel filter, sounds like fuel starvation. Fuel filters probable the cheapest and easiest try 1st.
__________________
2012 Journey 40U (Our Incredible Journey)
2008 Dodge Dakota(TOAD) 2005 Honda Shadow in TOAD
AF-1 braking system
D Lindy is offline   Reply With Quote
Old 07-05-2014, 08:43 PM   #9
Senior Member
 
vsheetz's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Jun 2012
Location: SoCal
Posts: 13,668
Finally getting around to revisiting this. Pulled the fuel line loose at the engine. When pushing switch to prime has a strong flow. Removed the 2nd of two filters at the engine (other is down below next to the fuel pump) and put on the loose end of the fuel line. Still a strong flow. When pushing the switch to start, the flow is good for a few seconds, then stops - appears the logic is telling it to shut off.

Methinks next is to go to a shop for service. Thoughts on going to a RV repair shop vs. Onan service center?
__________________
Vince and Susan
2011 Tiffin Phaeton 40QTH (Cummins ISC/Freightliner)
Flat towing a modified 2005 Jeep (Rubicon Wrangler)
Previously a 2002 Fleetwood Pace Arrow 37A and a 1995 Safari Trek 2830.
vsheetz is offline   Reply With Quote
Old 07-06-2014, 07:34 AM   #10
JC2
Senior Member
 
JC2's Avatar
 
Newmar Owners Club
Texas Boomers Club
Join Date: Dec 2003
Location: Mo/Texas
Posts: 3,259
Quote:
Originally Posted by vsheetz View Post
Finally getting around to revisiting this. Pulled the fuel line loose at the engine. When pushing switch to prime has a strong flow. Removed the 2nd of two filters at the engine (other is down below next to the fuel pump) and put on the loose end of the fuel line. Still a strong flow. When pushing the switch to start, the flow is good for a few seconds, then stops - appears the logic is telling it to shut off.

Methinks next is to go to a shop for service. Thoughts on going to a RV repair shop vs. Onan service center?

Onan service center for genie. Hrly cost should be close and that's what there for.
__________________
2010 Newmar Dutch Aire DP 4304-Cummins ISL 425hp-Spartan MM Chassis-2013 Chev Equinox AWD-Ready Brute Elite Towing System-FMCA 402879-SKP 120487
JC2 is offline   Reply With Quote
Old 07-06-2014, 07:39 AM   #11
Senior Member
 
94-Newmar's Avatar
 
Join Date: Nov 2009
Posts: 2,043
In post #6 above I had asked for your model number... :-)

You mention when pushing START the flow from the fuel pump is good for a few seconds then stops.. but is the engine cranking? There is no logic built-in on any model that will stop the fuel pump while you're still cranking.. your model # is a must to help any further :-)
__________________
94-Newmar Kountry Star 40-KSDP
Spartan/Cummins 8.3C-300HP/Allison 3060 WTEC-II/25yr RV Tech RVIA Certified/Onan-Cummins Certified
94-Newmar is offline   Reply With Quote
Old 07-06-2014, 11:29 AM   #12
Senior Member
 
vsheetz's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Jun 2012
Location: SoCal
Posts: 13,668
Yes, The cranking and the fuel flow stop at the same time.

Model number below

Click image for larger version

Name:	ImageUploadedByiRV2 - RV Forum1404664035.404836.jpg
Views:	72
Size:	993.2 KB
ID:	67028Click image for larger version

Name:	ImageUploadedByiRV2 - RV Forum1404664105.720418.jpg
Views:	75
Size:	792.3 KB
ID:	67029Click image for larger version

Name:	ImageUploadedByiRV2 - RV Forum1404664125.417643.jpg
Views:	71
Size:	840.9 KB
ID:	67030
__________________
Vince and Susan
2011 Tiffin Phaeton 40QTH (Cummins ISC/Freightliner)
Flat towing a modified 2005 Jeep (Rubicon Wrangler)
Previously a 2002 Fleetwood Pace Arrow 37A and a 1995 Safari Trek 2830.
vsheetz is offline   Reply With Quote
Old 07-06-2014, 11:59 AM   #13
Member
 
Robertandkim's Avatar
 
Join Date: May 2013
Posts: 74
I took mine to cummings/onan Rocky Mountain in Salt Lake City. They have centers all over the west. They have techs that work on generators all day every day and they usually have parts in stock. Their not cheap but they know what their doing.
Robertandkim is offline   Reply With Quote
Old 07-06-2014, 01:04 PM   #14
Senior Member
 
94-Newmar's Avatar
 
Join Date: Nov 2009
Posts: 2,043
Ok, HGJAB ... look at the bell end of the generator housing- you should be able to see part of the rotor. While you're cranking is the center section of the generator turning exactly in speed/rotation with the engine while cranking? Pay careful attention that it does not move at all after the engine stops cranking. This model is notorious for either a broken or slipped drive belt and/or belt tensioner that galls up and allows the belt to slip. A 32 error on these units are either a faulty drive system as mentioned above OR brushes/slip ring issues.
__________________

__________________
94-Newmar Kountry Star 40-KSDP
Spartan/Cummins 8.3C-300HP/Allison 3060 WTEC-II/25yr RV Tech RVIA Certified/Onan-Cummins Certified
94-Newmar is offline   Reply With Quote
Reply

Tags
generator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Generator auto start says LOCKED OUT Matchayan Monaco Owner's Forum 5 04-15-2014 12:41 AM
No power to coach unless RV is running dvleemin Class A Motorhome Discussions 9 03-27-2014 08:33 PM
Diesel Onan wont start texasbob1945 Class A Motorhome Discussions 18 12-08-2013 02:50 PM
Cummins 8.3 won't start. '95 Winnebago Luxor Bwainsp Cummins Engines 11 10-28-2013 11:15 AM
My 1998 Cummin 5.9L won't start SuperDad Cummins Engines 18 10-08-2013 02:42 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:40 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.