Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-14-2017, 02:38 AM   #1
Senior Member
 
GearGirl's Avatar
 
Fleetwood Owners Club
Join Date: Oct 2015
Posts: 118
Inverter "Chatter" when Plugged into 20A Outlet

Hi folks, got another one. While I AirBnB my house (and until it sells), the cats and I are living in my RV. Weather is good and no aircon needed (I'm in Scottsdale, AZ), so I figure just run a short-ish extension cord from one of my exterior bricks and mortar outlets to a couple of adapters and to my usual 50A RV cord. At any given time, I'm using 1-4 A per the readout on my Intellitec control panel up front. Maybe once or twice a week I'll use my hair dryer (after shutting everything else off) so I'll be pulling 11A for 20 or so minutes.

My inverter chatters. It's not clicking like I've read others deal with. It's like...a vibration? Very odd sound. And then sometimes it ceases (right this minute it stopped FOR NOW). I can't come up with a use pattern that explains why - it was chattering for the past 2 hours then SILENCE and all I've got on are overhead incandescent 12V lights in bedroom and a 120V ac LED strip in living area.

Ideas? 2005 Fleetwood Expedition 38N, xantrex freedom 458 inverter/charger. Charge/Gel 1 light illuminated. Now it's chattering again. Sounds like an old school alien invasion video game.

Thanks!
__________________

__________________
GearGirl is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-14-2017, 04:55 PM   #2
Senior Member
 
Lt Dan's Avatar


 
Tiffin Owners Club
Join Date: Sep 2013
Location: DFW, Texas
Posts: 1,655
It's quite possible that the extension cord you are using is too small and/or too long to carry the amperage. A lightweight cord will cause the voltage to drop too much over the length of the run, especially if it's 50-100 feet. A heavier gauge cord might help.
__________________

__________________
Dan & Ro with two Rescued Boston "Terrorists" Jade & Jewel
2017 Phaeton 40IH Maroon Coral - Power Glide Chassis with IFS (05/17)
Previously '15 Tiffin Allegro RED 38QRA and '06 Itasca Sunrise 35A
'12 Jeep Wrangler Sport and/or '08 Honda Goldwing
Lt Dan is offline   Reply With Quote
Old 11-14-2017, 08:53 PM   #3
Senior Member
 
GearGirl's Avatar
 
Fleetwood Owners Club
Join Date: Oct 2015
Posts: 118
Thanks man, but it's a 20 foot 12AWG extension cord. Should be fine?
__________________
GearGirl is offline   Reply With Quote
Old 11-15-2017, 08:23 AM   #4
Senior Member
 
charles tuit's Avatar
 
Winnebago Owners Club
Join Date: Feb 2008
Location: prescott az
Posts: 728
Are you sure it is the inverter/charger that is chattering? Sounds like the transfer switch. Unplug from electrical input, open the transfer switch and tighten all connections.

Hope this helps.
__________________
Charlie Tuit, 2002 Journey, 32T, XL7 toad
charles tuit is offline   Reply With Quote
Old 11-19-2017, 01:17 AM   #5
Senior Member
 
GearGirl's Avatar
 
Fleetwood Owners Club
Join Date: Oct 2015
Posts: 118
If I can figure out how to attach a sound bite I will.
__________________
GearGirl is offline   Reply With Quote
Reply

Tags
inverter



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
A "Camper" is a "Camper, and a"Trailer" is a "Trailer"! OHVtime iRV2.com General Discussion 31 10-22-2017 08:57 AM
Question on "power selector" 50A, 30A, 20A, Gen on new coaches brokenrule RV Systems & Appliances 7 07-04-2017 11:36 AM
12 Volt outlet frying small outlet inverter RVer402 MH-General Discussions & Problems 23 01-21-2016 05:27 PM
Low voltage in coach with correct volts at outlet where plugged into freen03 Newmar Owner's Forum 46 08-28-2014 05:21 PM
12V Converter Blowing 20A Fuse C Rob Truck Camper Discussion 15 08-26-2007 07:49 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:38 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.