Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-17-2011, 04:19 AM   #1
Senior Member
 
SCVJeff's Avatar
 
Join Date: Dec 2006
Location: Santa Clarita, CA.
Posts: 2,373
Just Installed a Magnum Power MS-2000

... Something I have wanted to do for a long time and finally got around to swapping the factory Dimensions with the MS-2000..

One thing I notice is that the reported charge/ discharge rates are WAY off.. ! The spec's say reported current (at the panel) is +-20%, and I'm seeing 25%. In other words, the panel is showing a charge of 108A, and my known accurate amp clamp is reporting 78A. On the discharge (Inverter) side it shows a 15A draw from the coach, and my amp clamp is showing 20-22A ... that's nuts.. It's not just me, I saw the same thing with a friends unit recently while camping.

Is anyone aware of a calibration procedure for this unit? I will definitely call the factory on this one but figured I'd check here 1st.
__________________
_______________________________

Jeff - WA6EQU
'06 Itasca Meridian 34H, CAT C7/350
SCVJeff is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Reply

Tags
power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NO DC POWER but have AC Power: Here is what I found out first5thwheel 5th Wheel Discussion 0 05-20-2011 01:29 AM
2000 Dutchstar - power jack problem! rkravontka Newmar Owner's Forum 7 05-16-2011 04:28 PM
Inverter/Charger power interruptions mtnman49 National RV Owner's Forum 6 11-10-2010 05:59 AM
Shore Power: Breaker Off before Connecting or Disconnecting Always-RVing MH-General Discussions & Problems 18 11-13-2009 05:10 PM
Power Steering Fluid Change W/Filter Mutt Monaco Owner's Forum 1 10-25-2009 08:36 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:14 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.