RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-22-2018, 10:44 PM   #1
Junior Member
 
Join Date: Aug 2017
Posts: 5
kwikee leveler issue

2007 Winnebago Itasca Sunrise 35A, Ford Chassis, V10. Yesterday tried auto levelers for first time in months. No lights on Kwikee panel, push buttons no action. There is power to panel. Unplugged all leads into kwikee panel. Gave it a stern talkin too !! Hooked back up. Only able to lower r side by pushing right arrow, able to lower left side by pressing left arrow, same for front and rear. AUTO MODE only lowers left front. light remains on for right front but it is stowed all the way up. The 'ALL UP" works. Park brake works and lights up on dash. thx in advance Don
Attached Thumbnails
Click image for larger version

Name:	kwikee.jpeg
Views:	10
Size:	191.8 KB
ID:	211993  
__________________

car54don is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-23-2018, 03:12 AM   #2
Senior Member
 
Join Date: Jun 2016
Location: Nine Mile Falls WA / Arizona City AZ
Posts: 703
So you have power to the panel, what kind of condition is the ground circuit?


The panel will need a ground to work and each of the solenoids will need a ground connection to work?
__________________

__________________
Retired Business Owner, Re-manufacturing HD Clutches, Brake Shoes, Air Compressors, Sales & Installation of PacBrake and other Industrial Friction
jelag is offline   Reply With Quote
Old 07-23-2018, 03:52 AM   #3
Senior Member
 
scooterbob's Avatar
 
Winnebago Owners Club
Nor'easters Club
Join Date: Oct 2012
Location: South Jersey
Posts: 701
I never use the auto mode nothing but trouble.
__________________
Bob & Karen & Buddy "yourkie"
2008 Winnebago 39W Destination DP
Full time One Destination at a time.
scooterbob is offline   Reply With Quote
Old 07-24-2018, 12:15 PM   #4
Senior Member/RVM #90
 
MSHappyCampers's Avatar


 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 31,776
Hi ! Welcome to IRV2! We're sure glad you joined the gang!

I'm not familiar with that system. Wish I could help......


Good luck, happy trails, and God bless!
__________________
Joe & Annette

2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is offline   Reply With Quote
Reply

Tags
kwikee



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kwikee Level Best leveler problem... Motor7 MH-General Discussions & Problems 10 04-01-2016 04:00 PM
Kwikee leveler problem Luv 2 travel Fleetwood Products Owner's Forum 0 10-21-2010 09:35 PM
Kwikee Step not so Kwikee lincolncent MH-General Discussions & Problems 6 09-01-2010 09:35 AM
08' Diplomat Leveler Control Panel issue flyinraptr Monaco Owner's Forum 3 04-19-2010 02:36 PM
Kwikee Leveler Problem Wayne M Winnebago Industries Owner's Forum 2 02-13-2009 12:20 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:43 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.