Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-22-2011, 04:29 PM   #1
Senior Member
 
Country Coach Owners Club
Join Date: Jan 2006
Location: Redding
Posts: 3,395
Link 2000 Battery Monitor is Flakey

I installed a Link 2000 Battery Monitor/Invertor controller about 4 years ago.

After replacing both the chassis and house battery banks this Summer, it appears that the Amp % (remaining) and Amp Hours reported are not accurate.

1. Amp % is -504 and Amp Hrs rapidly builds to -1500 hours when the inverter is in the Accept or Float mode.

2. The LoBatt signal continues to flash on the meter.

Battery voltage reported matches the multi-meter reading at the battery terminals.

I have:
a. done the Microprocessor Reset Procedure several times.
b. restored the Factory Default several times.
c. reset the Amp Hours to zero several times.
d. reset the functions several times.
e. reset the Battery specifics.
f. verified that the color coded wires are correctly connected and applied to the correct spots on the Shunt.

The Link 2000 controls a Heart Freedom 25 and is supposed to report on a House wet cell Battery bank of 440 Amp Hrs.

Basically, it functions well as a volt meter and inverter controller but not as a Battery monitor


So.................

Has anyone had this type of problem and any success in correcting same?
__________________

__________________
Dean
1995 CC Magna #5280
C8.3L 300hp Cummins, 31,000lbs
deandec is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-23-2011, 02:41 AM   #2
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
Good question; I would call Xantrex about the issue. They can tell you how to diagnose if it is the shunt or controller.
__________________

__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 01-23-2011, 09:22 AM   #3
Senior Member
 
Join Date: Nov 2007
Location: somewhere in the west
Posts: 1,168
Quote:
Originally Posted by RV Wizard View Post
Good question; I would call Xantrex about the issue. They can tell you how to diagnose if it is the shunt or controller.

Go to the source . . . now that's good advice, always.

Ed
__________________
Ed-Sommers is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Replacing 12 volt Converter and Battery Charger DriVer RV Systems & Appliances 13 08-22-2011 10:32 AM
Battery Charging Questions INSPECTORBOB Winnebago Industries Owner's Forum 14 10-20-2010 09:26 AM
Battery explosion Daysu47 Winnebago Industries Owner's Forum 5 11-14-2008 05:16 PM
Dead Starting Battery on new Access Coach ctcamper Winnebago Industries Owner's Forum 11 09-10-2007 02:36 PM
Installation of a Battery Disconnect Switch SteveG Winnebago Industries Owner's Forum 7 07-09-2007 06:53 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:20 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.