RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-03-2019, 09:05 AM   #1
Member
 
Join Date: Sep 2011
Posts: 35
Norcold 1200 LP Problem

I have a 1200 Norcold refer in a 2005 HR endevour. This weekend the LP stopped working. It lights but only stays on for around 2 minutes then shuts off. It does this a couple times then stops all together. Fridge never sets off an alarm either. It still works on 120V but when you open the door the "dr" code goes off?? I assume it's 2 problems but LP is what I'm going to start with. Thanks
__________________

corcon is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-03-2019, 09:15 AM   #2
Senior Member
 
Join Date: Jul 2018
Posts: 1,376
The dr code is telling you the door is not fully shut.

You say it works on 120v - does it fully cool down? If so, your problem is with the burner or its controller. Hopefully the iRV2 user Old Biscuit will see this post and offer his accumulated wisdom and experience with these units.
__________________

__________________
2005 Four Winds Majestic 23A
“To the world you may be one person; but to one person you may be the world.” - Dr Suess
Solo_RV_Guy is offline   Reply With Quote
Old 09-03-2019, 09:36 AM   #3
Member
 
Join Date: Sep 2011
Posts: 35
It cools well on 120v. Just odd the dr code started coming on at the same time as the LP problems. And it comes on as soon as you open the door? I assume it's 2 problems.
corcon is offline   Reply With Quote
Old 09-03-2019, 10:05 AM   #4
Senior Member
 
Join Date: Nov 2015
Posts: 10,668
Flame Lights off but only for a couple minutes then goes out....retries then shutsdown


Flame Proving is not happening
I'm surprised you are not getting a fault code *NO in display and Gas LED FLashing


Start with the basics
Are the burner slots clear/clean of rust?
What does Flame look like when it lights off......should be strong BLUE all slots and reach up inside flue opening


Spark electrode.....
Should be engulfed in Flame when it lights off
Spark gap ......1/8" - 3/16"
Electrode needs to be CLEAN of soot/carbon so flame signal can be detected
Electrode wire connection at transformer on circuit board needs to be clean/tight


Gas Valve.......
Get DC Voltage when Spark Electrode is firing.
DC only stays on Gas Valve if flame proves and continues to prove it has lit off. via spark electrode

Loose/bad ground from solenoid will cause loss of DC at gas valve
Should have 12VDC at terminals GV and GV_GRD




This is what the burner flame should look like







'dr' alarm
Should only come on when door is open for more then 2 minutes which is a very long time


Door striker plate, door alignment, door switches
__________________
Is it time for YOUR Medication or Mine?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 09-03-2019, 10:22 AM   #5
Member
 
Join Date: Sep 2011
Posts: 35
Thanks.Stuff to check
corcon is offline   Reply With Quote
Old 09-03-2019, 01:33 PM   #6
Member
 
Join Date: Sep 2011
Posts: 35
Burners clean,1/8" between the burner and the electrode and 12V at the gas valve terminals. Last time we tested it barely even stays on when it fires. I tried going from LP to AC and I had to play with the buttons for a while before it would change. Any other ideas would be helpful.
corcon is offline   Reply With Quote
Old 09-04-2019, 07:47 AM   #7
Member
 
Join Date: Sep 2011
Posts: 35
After more testing I noticed the door doesn't shut the light off in the fridge. Also I found a service manual online. It shows my fridge has a diagnostic mode. We tried to use it but the fridge shuts off before we can get anywhere. I'm thinking I need a board kit,both boards. Anyone use the Norcold Guy online?
corcon is offline   Reply With Quote
Old 09-04-2019, 08:42 AM   #8
Senior Member
 
Scotialaddie's Avatar
 
Monaco Owners Club
Join Date: Nov 2016
Posts: 179
My Norcold is also shutting off on propane. Flame is good, igniter is clean and positioning is correct. But after operating for 5 or more minutes I can hear it trying to trying to ignite even though it has a good flame. After several try’s it shuts down the propane and I get the no Lp alarm. I’m guessing it’s the control board. Anyone have this problem before.
__________________
Scotia, Tricia, Mia, (the Labradoodle)
1999 Monaco Dynasty
330hp Cummins, Allison 6 speed
Scotialaddie is offline   Reply With Quote
Old 09-04-2019, 09:18 AM   #9
Member
 
Join Date: Sep 2011
Posts: 35
Mine doesn`t even try to light after the initial fire up. Yours sounds like maybe air pocket. Fire up the stove burner for 10-15 seconds then try it again.
corcon is offline   Reply With Quote
Old 09-16-2019, 09:02 AM   #10
Member
 
Join Date: Sep 2011
Posts: 35
Just a heads up on my problem. I got a control board off Amazon and it seems all fixed. At least the alarms work now.
corcon is offline   Reply With Quote
Old 09-20-2019, 02:42 PM   #11
Member
 
Join Date: Sep 2011
Posts: 35
Good afternoon. I just finished changing the control board and the eyebrow board as well as the thermistor. Everything seems to work ok at first. I start it on AU and let it go to LP. The propane lights and runs for a couple of hours then shuts off. I get a NO CO code and beeping. This is a good thing as before I got no code or alarm. I did notice once I opened the fridge door that the interior light had fallen out. When I went to replace it I noticed one of the fingers that hold the light in is cracked and doesn't hold the light in anymore. The thermistor gets its power from the light so I hope it might be that. If anyone has any info that would be great. Thanks
corcon is offline   Reply With Quote
Old 09-21-2019, 12:58 PM   #12
Senior Member
 
Join Date: Nov 2015
Posts: 10,668
Read about the 'Cooling Unit Monitoring Control Operation' on pg 33


Thermistor...pg 29


https://www.thetford.com/wp-content/...68C_022707.pdf
__________________
Is it time for YOUR Medication or Mine?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 09-23-2019, 05:35 PM   #13
Member
 
Join Date: Sep 2011
Posts: 35
Thanks for the link. I cleaned the venting at the rear of the fridge and made sure the thermistor was sitting flat on the fin. I turned it on with 120v and everything worked great for 36 hours. Then I turned it to LP and it kept it cold for another 36 hours. I thought everything was fixed but I was wrong. I shut everything down for about 8 hours with the doors open. I then tried to cool it on LP only from the beginning. I went in 3 hours later and the fridge was beeping flashing "no co" and the flame was off. The tank for the cooling unit was very warm still.( I don't know how long the flame had been out) I'm totally lost.Any other ideas?
__________________

corcon is offline   Reply With Quote
Reply

Tags
norcold, problem



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Norcold 1200 gas problem? csrrsr RV Systems & Appliances 7 05-20-2013 09:16 PM
Norcold 1200 Series Refrigerator Problem Punks385RLS RV Systems & Appliances 16 03-24-2013 09:30 AM
Norcold 1200 AC side problem peliaspastia RV Systems & Appliances 12 09-12-2012 08:38 PM
Norcold 1200 RIM Ice Maker Problem cjean RV Systems & Appliances 5 08-14-2012 12:35 PM
Problem with 6 year old 1200 series norcold refrigerator grherberger RV Systems & Appliances 2 07-02-2012 09:11 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:08 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×