RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-03-2014, 06:26 PM   #1
Junior Member
 
Join Date: Mar 2014
Posts: 27
Not working Emergency brake/ leveling jacks/ slide.

Hi all. First off I'm a noob. And I tried to find a thread that already had topic but could not find. So I'm sorry if posting in wrong spot. Anyway I was in rush today so when I park rv I put jacks down and put 1 slideout out and had to leave. When I gat back to site I plugged in and. Went inside to put other slide out but nothing happened no motor noise or anything. So I started rv just too try it, as soon as I started it the jacks came up. So I released emergency brake and pushed back in but no brake light came on. So now jack won't come on. Can someone point me in direction to start looking. 2001 fleetwood flair 31a. Thank you
__________________

Jayrock3570 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-03-2014, 06:38 PM   #2
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 16,979
The " no brake set light " is part of the problem. What chassis, is your coach built on , Ford , Workhorse ?
__________________

__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 04-03-2014, 06:49 PM   #3
Junior Member
 
Join Date: Mar 2014
Posts: 27
Ford f-53. Ok I gat emergency brake to work by playing with it a little but does not work everytime. And jacks work when emergency light comes on but not dinnet slide. Bedroom slide works thou. Thanks again.
Jayrock3570 is offline   Reply With Quote
Old 04-06-2014, 09:24 PM   #4
Senior Member
 
Robin_M's Avatar
 
Monaco Owners Club
Join Date: May 2007
Location: SE Pennsylvania
Posts: 1,806
Blog Entries: 2
Not familiar with the Ford chassis, but if you are still having a problem, I'd suggest you look for a blown fuse. On my coach there are fuses in the power feeds to the safety circuits - like the circuit that brings your jacks up when you start the engine or release the parking brake, and the one that won't allow you to put a slide out while the engine is running, etc. Perhaps your coach may have similar fuses.
__________________
Rob.......Links to coaches below
New (to us) 2016 Tiffin Allegro Bus 45 OP
2017 & 2007 Monaco Diplomat Sites
Robin_M is offline   Reply With Quote
Old 04-06-2014, 11:43 PM   #5
Junior Member
 
Join Date: Mar 2014
Posts: 27
Thanks. And yes slide still stuck in. I checked the fuses I could find. Some inside by breakers and some in the engine compartment. Tried to look under dash on driver side for more fuses to check. But I'm to fat to get a good look. Was your fuse a standard car fuse like 5 to 25 amps. The funny thing is the rear slide works find.
Jayrock3570 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Leveling jacks taking forever! jim1eddoc Winnebago Industries Owner's Forum 82 08-31-2014 06:32 PM
Leveling jacks orrconst Class A Motorhome Discussions 10 02-18-2014 05:36 PM
Bounder: Slide outs and leveling BarryN514 Fleetwood Products Owner's Forum 14 02-03-2014 05:28 PM
Hwh leveling jacks jym New Member Check-In 10 11-18-2013 07:36 AM
Engine brake stopped working. '03 Discovery RobertDavis Caterpillar Engine Forum 3 09-08-2013 08:31 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:01 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.