RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-02-2015, 10:55 PM   #1
Senior Member
 
Longweekends's Avatar
 
Fleetwood Owners Club
Join Date: Apr 2012
Posts: 205
Steps stopped working suddenly

On my 06 Tradition, my steps stopped working after a short 30 miles trip from my home to my warehouse. They will not come down now.I've heard about a safety lockout switch that sometimes malfunctions and prevents them from extending. Anybody have any experience with this switch? Any ideas of where else to check besides just the fuse under the steps?
__________________

__________________
American Coach Tradition 2006
No toad, just 2 bicycles
12 year old cocker spaniel "Peanut"
Longweekends is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-03-2015, 06:31 AM   #2
Senior Member
 
Join Date: Feb 2010
Posts: 507
Check the contacts....should be on the door and jam...
__________________

GENECOP is offline   Reply With Quote
Old 06-03-2015, 06:36 AM   #3
Community Administrator
 
CLIFFTALL's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Aug 2009
Posts: 37,742
Besides the contacts mentioned above ,there are two fuses ( step switch and step motor ). These were in the BCC ( battery control center ) on my Bounder. Here is a photo of the BCC schematic,
Click image for larger version

Name:	ImageUploadedByiRV2 - RV Forum1433331377.945634.jpg
Views:	100
Size:	260.8 KB
ID:	96085
__________________


Cliff,Tallulah and Buddy ( 1999-2012 )
CLIFFTALL is offline   Reply With Quote
Old 06-03-2015, 02:47 PM   #4
Senior Member
 
Tha_Rooster's Avatar
 
Join Date: Aug 2008
Location: Georgia
Posts: 5,740
Steps stopped working suddenly

Check ground wire first then due kwikee trouble shooting on web site be careful underneath in case they start working. This also should be moved its not a chassis issue.
__________________
2007 Fleetwood Revolution LE 40V
Tha_Rooster is offline   Reply With Quote
Old 06-03-2015, 03:48 PM   #5
Senior Member
 
dennis45's Avatar
 
Join Date: Jun 2012
Location: AB
Posts: 7,572
Quote:
Originally Posted by Longweekends View Post
On my 06 Tradition, my steps stopped working after a short 30 miles trip from my home to my warehouse. They will not come down now.I've heard about a safety lockout switch that sometimes malfunctions and prevents them from extending. Anybody have any experience with this switch? Any ideas of where else to check besides just the fuse under the steps?
Do you give them a shot of lube once in a while? Does not take much resistance to make them stop moving. I am using the T9 Boshield spray lube for all things hinge and it works well. WD40 sucks in this application.
__________________
2019 Unity LTV CB, pushed by a 2013 Honda CRV, BlueOx Baseplate, Aventa Bar & Patriot Brake
dennis45 is offline   Reply With Quote
Old 06-03-2015, 03:52 PM   #6
Senior Member
 
Join Date: Oct 2011
Posts: 251
I had the same problem a while back. Just needed to be lubed.
__________________
2011 Monaco Knight 36', MaxForce 10, 350HP, 1150 lbs. Torque.
2008 Saturn Vue Toad, SMI Duo Brake, Roadmaster Sterling Tow Bar
San Antonio, TX Home Port
wigginsjsr is offline   Reply With Quote
Old 06-03-2015, 03:58 PM   #7
Senior Member
 
dennis45's Avatar
 
Join Date: Jun 2012
Location: AB
Posts: 7,572
Quote:
Originally Posted by wigginsjsr View Post
I had the same problem a while back. Just needed to be lubed.
Always try the easy route first.
__________________
2019 Unity LTV CB, pushed by a 2013 Honda CRV, BlueOx Baseplate, Aventa Bar & Patriot Brake
dennis45 is offline   Reply With Quote
Old 06-04-2015, 11:05 PM   #8
Senior Member
 
Longweekends's Avatar
 
Fleetwood Owners Club
Join Date: Apr 2012
Posts: 205
Thanks guys. I certainly hope it is something so simple. I have my doubts it's just lube needed because I've been using them a lot and they worked an then stopped working 30 minutes later. Will keep you posted.
__________________
American Coach Tradition 2006
No toad, just 2 bicycles
12 year old cocker spaniel "Peanut"
Longweekends is offline   Reply With Quote
Old 06-05-2015, 06:45 AM   #9
Senior Member
 
wildtoad's Avatar
 
Join Date: Jul 2010
Posts: 4,198
Mine quit a while back. Checked and/or made sure all connections were good. Tapped the motor with a hammer and started working again. Then lubed everything.
__________________

__________________
Tom Wilds
Blythewood SC
2016 Newmar Bay Star Sport 3004
2015 Jeep Wrangler 2DR 4WD Sahara, Automatic, Hard Top
wildtoad is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slide stopped working after unlocking bokobird Newmar Owner's Forum 5 07-04-2014 07:55 AM
App Stopped Working ImagineIF Forum 101 | Announcements | Member Forum Concerns 25 07-02-2014 06:46 PM
Black tank flush stopped working Alan Wilson RV Systems & Appliances 29 05-19-2014 02:13 PM
Spark Igniter stopped working bdickson RV Systems & Appliances 3 04-12-2014 06:17 PM
Dometic Refridge Stopped Working in Cold Weather sctdixon RV Systems & Appliances 10 12-13-2013 09:07 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:41 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×