Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-31-2010, 08:10 PM   #1
Member
 
cirquegirl's Avatar
 
Fleetwood Owners Club
Join Date: Jul 2009
Posts: 45
Took Delivery on 2004 Excursion - Fridge Problem

We picked up a 2004 Excursion this week in AZ. I love it! One problem we are having is that when hubby drove it back the first night when they stopped the Norcold Fridge gave an alarm and a "no co" error. He reset it and then it started working. The next night same thing but on reset - no dice......everything I am seeing the the manual says you have to take it to a service center to have it worked on. What could possibly be wrong. I don't think this coach was ever lived in. I think whoever owned it used it as a traveling office as it has a desk in it rather two sofas. All appliances appear to never have been used as well as drawers and bed.

Any help on the refrigerator problem would be welcome. Can't wait to take a trip in it but need the refrig to be working.
__________________

__________________
cirquegirl is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-31-2010, 09:37 PM   #2
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 26,792
You may have tried to run with coach not level, your burner needs to be cleaned, cob webs in burner tube, rust in chimney tube that needs to be cleaned out or in burner slots. Lightly tap chimney to drop rust from interior of chimney place paper over slots to protect.Than vacume.
If it lights on gas than goes out sensor in flame needs to be cleaned with a cleaner do not scrap its ceramic coating.
Make sure your 12v connections are tight on wiring block floor of fridge in vent opening.
Congrats on your new motor home.
__________________

__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans, now in good hands
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 11-04-2010, 03:14 PM   #3
Senior Member
 
Join Date: Oct 2010
Posts: 421
007 had some good points to check. Seems like once a year I need to clean the pezio (spelling?) electrode. That is a spark plug to start the propane flame in the bottom area of the chimney. At different times I've used both steel wool and emery cloth to clean/shine the end that sits in the flame. When you re-install it after cleaning, it needs to be adjusted to 1/8th inch, or about the thickness of a nichol. Also, it doesn't take much of a cob-web to prevent the refer on gas mode, the water heater, or the furnace from working so I'd make sure there isn't any in the burner tube.
__________________
Poptop is offline   Reply With Quote
Old 11-05-2010, 03:50 AM   #4
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
Since the "no co" error has been displayed a few times the board is now in lock and can only be reset a couple of times by grounding certain terminals specific to the control board. The problem needs to be diagnosed as to why the control board does not see the cooling unit doing it's job properly within a three hour period. If you do not find and correct the problem and keep reseting the board, the board will go into a permanent lock out and cannot be reset.
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 11-06-2010, 05:54 PM   #5
Senior Member
 
scenic route's Avatar
 
Join Date: Jan 2010
Posts: 1,767
cirquegirl...The 'no' 'co' code indicates the heat sources for the cooling unit have been turned off. As RV Wizard indicated, after the first fault you can reset...after the second, the heat sources are 'locked out' and it's time to visit your local Norcold Service Center. Good time to see if your model is effected by the Norcold Recall as well. Good luck. Bob
__________________
Jan and Bob

RIP 'Squeaky'
scenic route is offline   Reply With Quote
Old 11-07-2010, 06:49 PM   #6
Member
 
cirquegirl's Avatar
 
Fleetwood Owners Club
Join Date: Jul 2009
Posts: 45
Well it is fixed and has been running all day so far.

Hubby got to the board and reset it. Somehow he blew a fuse during this process and after we found the fuse and replaced it and turned on the refrig it has been working fine now for about 12 hours now. Will let it run for about another 24 to make sure. What made it shut down with the "no co" error code in the first place I don't know unless when he was traveling from AZ to MI he did not have the coach level when he stopped for the night.

I am crossing my fingers that this will fix the problem and save me a bunch of bucks.

Ours was not in the recall according to our local rv service center.
__________________
cirquegirl is offline   Reply With Quote
Old 11-07-2010, 06:54 PM   #7
Senior Member
 
Dirtbuster's Avatar
 
Fleetwood Owners Club
Join Date: Sep 2010
Posts: 272
You should check to make sure that you are not in the recall. Search the recall thread for more info. My guess is that you are!
__________________
Dirtbuster is offline   Reply With Quote
Old 11-07-2010, 07:12 PM   #8
Senior Member
 
Elkhartjim's Avatar


 
Newmar Owners Club
Texas Boomers Club
Freightliner Owners Club
Join Date: Jul 2008
Location: Don't mess with Texas
Posts: 3,116
I would strongly suggest you not rely on the Norcold website. Call them. I didn't give my serial number just the model number and they said..."recall".

I'm beginning to believe they are going to recall every unit they've manufactured and then when the recall fix fails they can sell us another unit.
__________________

__________________
Jim with Judy
2017 Newmar Ventana 4369, 2005 Jeep Wrangler (Rock Crawler), 2016 Jeep Wrangler (Mall Crawler)
Elkhartjim is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Another Norcold Fridge problem Suncruiser Ron MH-General Discussions & Problems 4 07-30-2008 09:49 AM
problems with Instamatic fridge nathanfox83 RV Systems & Appliances 3 12-18-2006 01:29 AM
another fridge problem Jim RV Systems & Appliances 7 08-09-2006 11:30 AM
2004 Sunrise Roof problem Dsouthw524 Winnebago Industries Owner's Forum 3 05-16-2006 09:01 AM
Fridge problem..suggestions needed. smlranger RV Systems & Appliances 10 05-18-2005 05:31 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:40 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.