RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-13-2019, 05:26 PM   #1
Junior Member
 
Join Date: Feb 2018
Posts: 14
Water heater no spark issue

Atwood GC10A-4E

My water quit working. I wasn't getting ignition (I couldn't hear the gas going either) nor was I getting heat on electric. I replaced the control board and now I have hot water on electric. I can also hear (and smell) the gas going but no spark. I replaced the ignitor but nothing changed. There is still no ticking sound (I can see that it isn't sparking). The only issue that I ran into when installing the new ignitor is that I couldn't get the sheet metal screw to go in straight and tighten up so I used a stainless steel bolt and nut. Do I need to have a sheet metal screw for it to ground properly? Could that stainless steel bolt be the problem? Or should I look somewhere else? I tried a new thermal fuse (I have a spare) and tried bypassing the t-stat. Neither of those affected anything.

Any suggestions?
__________________

callcameron is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-13-2019, 11:05 PM   #2
Senior Member
 
Join Date: Nov 2015
Posts: 11,025
Stainless is OK for ground


What is the Spark GAP
S/B 1/8" to 3/16"
And High Tension Wire needs to have a clean/tight connection at transformer on circuit board
Wire can not be loose inside the Ceramic Insulator
Spark Electrode must be engulfed in flame when it ignites






FYI.......
Thermal Fuse or Bad t-stat----electric wouldn't work ----use the same circuit
__________________

__________________
Is it time for YOUR Medication or Mine?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 10-16-2019, 09:45 PM   #3
Junior Member
 
Join Date: Feb 2018
Posts: 14
Quote:
Originally Posted by Old-Biscuit View Post
Stainless is OK for ground


What is the Spark GAP
S/B 1/8" to 3/16"
And High Tension Wire needs to have a clean/tight connection at transformer on circuit board
Wire can not be loose inside the Ceramic Insulator
Spark Electrode must be engulfed in flame when it ignites






FYI.......
Thermal Fuse or Bad t-stat----electric wouldn't work ----use the same circuit
Thanks. I'll check that tomorrow. I was pretty sure a bad thermal fuse or t-stat would kill the electric as well but I was just trying to eliminate things.
callcameron is offline   Reply With Quote
Reply

Tags
heat, heater, water, water heater



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Burnt Spark Plug Issue Apply to 2004 Newmar Scottsdale? fishmaine Newmar Owner's Forum 4 01-18-2019 02:03 AM
87 Eldorado Prelude - no spark issue freetrapper Vintage RV's 8 05-30-2018 06:27 PM
2010 E450 V10 spark plug issue JF1957 Ford Motorhome Chassis Forum 3 03-24-2017 04:03 PM
Atwood Water Heater; No Spark, No Gas retmotor RV Systems & Appliances 15 02-13-2014 05:32 AM
Replacing Water heater with tankless water heater? JAFORV2012 Class A Motorhome Discussions 5 09-24-2012 07:48 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:27 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×