Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-05-2012, 01:14 PM   #1
Senior Member
 
National RV Owners Club
Join Date: Mar 2011
Posts: 507
Water Pump won't pump water

I inadvertently let the water tank run out of water and now the pump runs but no water out. Did I screw up the pump or is there air in the lines, etc.? City water works as it should. How do I get air out if that's it?

Thanks

John
__________________

__________________
John & Deanie, Corky and Benji (best buddies)
2001 National Marlin 390 DP
"Try to live up to your dog's opinion of you."
zzjea is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-05-2012, 01:32 PM   #2
Senior Member
 
puttin's Avatar


 
Winnebago Owners Club
Ford Super Duty Owner
Join Date: Dec 2009
Posts: 861
I had the same thing happen- try this- fill your water tank at least 1/4. Now, turn on the pump. If nothing comes out of the faucet, put your mouth up to it and suck. (please don't take offense to this). This will get the pump going again provided there isn't a clog or obstruction in the screen filter of the pump.
__________________

__________________
puttin is offline   Reply With Quote
Old 03-05-2012, 02:57 PM   #3
Senior Member
 
National RV Owners Club
Join Date: Mar 2011
Posts: 507
I just tried that, even used the vacuum on it. Nothing... This unit is supposed to be self-priming, so it is looking like the internals are gone. I'm looking online now to see if there are repair kits. ShurFlo 2088-403-144 2.8GPM.

We are going camping tomorrow and will have city water so I can wait until I get back to tackle this. I will empty the tank and then disconnect the pump and take it apart. I should be able to see what's wrong by looking or at least that's my plan.

Thanks. Any other ideas before I take it apart????
__________________
John & Deanie, Corky and Benji (best buddies)
2001 National Marlin 390 DP
"Try to live up to your dog's opinion of you."
zzjea is offline   Reply With Quote
Old 03-05-2012, 03:41 PM   #4
Senior Member
 
National RV Owners Club
Join Date: Mar 2011
Posts: 507
Problem Solved

I unscrewed the unit from under the bed and lifted it up a few inches while it was running and wallah, it primed itself (with my help). I guess the re-positioning of the unit and lines made the connection needed. Everything is working now.

Thanks.
__________________
John & Deanie, Corky and Benji (best buddies)
2001 National Marlin 390 DP
"Try to live up to your dog's opinion of you."
zzjea is offline   Reply With Quote
Old 03-06-2012, 04:07 AM   #5
Senior Member
 
puttin's Avatar


 
Winnebago Owners Club
Ford Super Duty Owner
Join Date: Dec 2009
Posts: 861
Good to hear you solved the issue without $$.
__________________
puttin is offline   Reply With Quote
Reply

Tags
water



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Water hose reel -- is it worth the $ okmunky RV Systems & Appliances 8 03-07-2012 12:00 PM
Third water pump switch?? Paul T Winnebago Industries Owner's Forum 20 03-06-2012 06:15 AM
Water Filter GlenB Fleetwood Products Owner's Forum 8 03-05-2012 02:52 PM
Purified vs distilled water USMCRET RV Systems & Appliances 11 03-05-2012 02:11 PM
Toilet won't hold water in the bowl michguy RV Systems & Appliances 25 03-05-2012 10:57 AM


All times are GMT -6. The time now is 03:37 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2014, vBulletin Solutions, Inc.