RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-27-2016, 11:38 AM   #1
Senior Member
 
Join Date: Sep 2015
Location: Austin, TX
Posts: 101
Windshield wipers stopped in the "up" position, not working!!!

Was driving my 2004 Tiffin Allegro Bus 38TGP back to the storage place last night when it started raining. Turned the wipers on and they worked fine for about five minutes. Then, all of a sudden they just stopped in the "up" position and would not come back on. Made it back okay, but I have tried manually moving them and checked the fuse - it's fine. They will NOT come back on. I have the Smartwheel control with the buttons on the steering wheel. Any ideas? I need to drive it this weekend and there is rain in the forecast.
__________________

Roamin Mike is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-27-2016, 05:58 PM   #2
Senior Member
 
Join Date: Jan 2015
Location: Prescott, Arizona
Posts: 1,796
Blog Entries: 6
I have the smartwheel on my rig. Had the same thing happen. Turned out to be the circuit board. Freightliner wanted $600+ but found one on line for around $300, new.
__________________
'04 Newmar MADP: 1Kw solar, Silverleaf, '17 Rubicon
ByeTheWay is online now   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windshield Wipers Not Working HDBiker Dave Newmar Owner's Forum 4 10-16-2018 10:54 AM
Windshield Wipers Stopped - in a SNOW Storm! pagosajoe Fleetwood Products Owner's Forum 4 05-23-2015 10:08 AM
'12 F53 windshield wipers not working H3OHIO Ford Motorhome Chassis Forum 2 11-22-2014 04:33 PM
Windshield Wipers Not Working standardbob National RV Owner's Forum 4 06-30-2012 08:09 AM
Wipers stopped working ElCajonee Damon 7 02-23-2012 02:24 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:03 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.