Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > iRV2.com General Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-28-2015, 11:56 PM   #1
Junior Member
 
Join Date: Mar 2015
Posts: 1
Unhappy 2006 Expedition problems

HELLO - HAVE TWO PROBLEMS - ONE IS, WHEN I TURN ON THE IGNITION, THE SPEAKERS ALL ACTIVATE WITH A LOUD STATIC SOUND (THE RADIO HAS NOT BEEN WORKING FOR SOME TIME) - CAN'T FIGURE WHERE TO START TO CORRECT THIS - WHERE IS THE FUSE FOR RADIO ? WHERE IS THE SPEAKER DISCONNECT (TEMPORARY)....
ALSO - ARE THE LEVELING JACKS OPERATED ELECTRICALLY? WHEN PUSHING THE CONTROL BUTTONS - NOTHING HAPPENS...
I DID PREVIOUSLY TAKEN IT TO THE SHOP AS THE DASH LIGHTS WERE FLASHING - THEY FOUND A BAD GROUND CONNECTION...
ANY HELP WOULD BE APPRECIATED - CAN'T DRIVE IT BECAUSE OF SPEAKERS,
LUCKILY THE LEVELING JACKS ARE UP (DID NOT TRY TO LOWER THEM AFTER RV WAS IN THE SHOP... THANKS - MARTY
__________________

__________________
mrfence94945 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-29-2015, 06:24 AM   #2
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
Hello Marty and We are glad to have you join us here and we look forward to reading of your adventures and experiences. I am sure you will enjoy our website and forums. Good luck, stay safe and keep us posted.
The speakers may have a "Dash/Stereo" switch in the driver upper cabinet on the left side wall. Fuses should be in the Battery Control Center (black box) driver side near the axle compartment and may have an inline fuse behind the stereo. Many times disconnecting the stereo power for a few seconds will reset the unit and it may work
The jacks have a main circuit breaker near the battery bank and a fuse in the Battery Control Center. Make certain the Brake is set and the engine should be running if it is Power Gear design to operate the leveling system.
__________________

__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 03-29-2015, 06:55 AM   #3
Senior Member
 
Bigd9's Avatar


 
Join Date: Jun 2012
Location: The Bluegrass State
Posts: 3,865
Good Morning Marty and Welcome!

According to the Fleetwood brochure for your coach the "jacks" are a 4-point Automatic Electric Leveler" system. There could be many reasons why they are not working. The RV Wizard gave you a good place to start. Does the leveling display panel show anything at all on it? Any lights showing it is alive? Do you hear any noises at all when you try and operate the stabilizers?

As for the radio, the fuse may be under the bed or accessed from the side of the bed frame. My coach (06 Discovery, a brother of yours) has a lot of fuses there.

Keep us posted as you work the problem.
__________________
Good Luck, Be Safe and Above All, Don't Forget To Have Fun
Pete
2006 Fleetwood Discovery 35H, being pushed by a 2014 Honda CRV
Bigd9 is offline   Reply With Quote
Old 03-29-2015, 11:40 PM   #4
Community Administrator
 
JohnRR's Avatar


 
Fleetwood Owners Club
Workhorse Chassis Owner
Join Date: Sep 2010
Location: Marquette, Michigan "Da UP"
Posts: 16,940
__________________
John & Cathy R.
06 Pace Arrow 38L W24
08 14 Lincoln MKX AWD
See My RV Upgrades
JohnRR is offline   Reply With Quote
Old 03-30-2015, 06:30 PM   #5
Senior Member
 
denlock's Avatar
 
Newmar Owners Club
Spartan Chassis
Join Date: Feb 2005
Location: Sterling Heights, MI
Posts: 2,723
__________________
Tricia & Dennis Lockhart
2010 Ventana 4333
Spartan MM w/Cummins 360 ISC
denlock is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 Fleetwood Expedition - Check Engine Light CurrentBoy Class A Motorhome Discussions 3 05-08-2014 04:00 AM
2006 Fleetwood Expedition CurrentBoy Fleetwood Products Owner's Forum 13 02-19-2014 05:25 PM
Help American Dream Water Problems GlennLever Fleetwood Products Owner's Forum 13 12-08-2013 07:44 AM
2 problems on recently purchased 2004 Expedition dakota pete MH-General Discussions & Problems 7 08-22-2013 09:13 PM
Cargo and Service Door Latch Problems '12 Expedition jsc Fleetwood Products Owner's Forum 2 06-08-2013 06:31 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:45 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.