Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > iRV2.com General Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-07-2016, 09:13 AM   #1
Junior Member
 
Join Date: Mar 2016
Posts: 4
AC -Air Conditioning

Ac works good and cold but just started coming out of the defroster vents not the dash. Ac radiator fan is not getting power to it. Ps I am not sure if there are tapped in as well, but my front steps will not lock by the switch unless key is on also electric jacks once key is turned on I get power for one second to the hydraulics and then no power. Don't know if these are all tied into one relay or not.
__________________

__________________
LennysRV is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-07-2016, 09:34 AM   #2
Senior Member
 
530ktm's Avatar
 
Join Date: Dec 2014
Location: Northern Arizona
Posts: 1,391
Usually when vents stop working properly there is a vacuum line involved that has started to leak. Not sure why this would be related to your other problems but some info on your coach would be helpful.
__________________

__________________
2014 Itasca Sunova 33C towing a Jeep JK Wrangler
530ktm is offline   Reply With Quote
Old 04-07-2016, 10:40 AM   #3
Moderator Emeritus
 
Bruce C's Avatar
 
Nor'easters Club
Fleetwood Owners Club
Workhorse Chassis Owner
Join Date: Dec 2011
Location: NH
Posts: 5,099
Parking brake on, in park, key on, you should have levelers. Check in the stair well [entry] for rocker switches that control your steps. Hope this helps.
__________________
Bruce & Nancy
FMCA F280542
2004 Bounder 35E
US Navy Vet.
Bruce C is offline   Reply With Quote
Old 04-07-2016, 03:04 PM   #4
Senior Member
 
TonyDi's Avatar


 
Join Date: Feb 2011
Location: Point Pleasant Beach, NJ
Posts: 10,442
Hi Lenny

At the top of the page you'll see a tab marked User CP. Click it and a drop down marked edit signature. You will be able to input info on your unit. It will help others know what you have and you'll get more responses.
__________________
Tony & Ruth........... FMCA#F416727
Newmar Dutch Star 4320, Spartan MM Chassis, Cat C9, Jeep Grand Cherokee Hemi, Blue Ox Aventa LX, and Brake Buddy. TST 507 TPMS
TonyDi is offline   Reply With Quote
Old 04-08-2016, 07:33 AM   #5
Junior Member
 
Join Date: Mar 2016
Posts: 4
AC National Tradewind 1999

Thanks. It is a 1999 National Tradewind. On a freight line chassis.
__________________
LennysRV is offline   Reply With Quote
Old 04-08-2016, 08:37 AM   #6
Senior Member
 
Join Date: Feb 2010
Posts: 4,493
If a DP then electric vacuum pump.

Possible blown fuse or loose wire as many electric things not working.

Pause a moment....Do you remember a motor running sound when key turned on and ac on but engine not running?

Turn key on and listen for vacuum pump ( if dp).

If none look for pump to check it out.

Also locate power distribution centers and or fuse blocks and check voltages with a voltmeter.
__________________
Tony & Lori
1989 Country Coach Savannah SE
TQ60 is offline   Reply With Quote
Old 04-08-2016, 08:45 AM   #7
Senior Member
 
jeepfreak's Avatar
 
Join Date: Mar 2003
Location: Home is where we park it
Posts: 417
When the heat/ac system loses vacuum the fail safe is to defrost. So either a broken vacuum line or vacuum pump failure.
__________________

__________________
2007 Allegro 34wa .WH w20 8.1 6speed. Bow tie powered 79 CJ7 or a 2014 Jeep Unlimited Rubicon Toad.
jeepfreak is offline   Reply With Quote
Reply

Tags
air conditioning



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dash Air Conditioning putting out hot air Knot-Flyn' Newmar Owner's Forum 19 08-19-2009 09:44 PM
Air Conditioning Vents turning Yellow jayhade Newmar Owner's Forum 9 01-09-2009 06:48 PM
Trany light and air conditioning??? roadtrec New Member Check-In 8 10-29-2007 05:24 AM
loss of air conditioning and fresh air through vents cwg Newmar Owner's Forum 2 03-31-2007 07:45 PM
Trany light and air conditioning??? Workhorse and Chevrolet Chassis Motorhome Forum 8 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:09 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.