Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > iRV2.com General Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-26-2011, 07:03 PM   #1
Junior Member
 
Join Date: Feb 2011
Posts: 18
Back up camera

Hi,

I meant to take apart my back up camera for a while and finally did it. The glass was dirty and I cleaned it and also cleaned the lense. Now I can't see nothing out of the monitor. It's just like a TV without a picture. what I've I done wrong? Any advise is welcome.

Maxi
__________________

__________________
maxi is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-26-2011, 08:18 PM   #2
Senior Member


 
Join Date: Nov 2009
Location: Big Bear Ca.(Sugarloaf)
Posts: 1,223
Maybe pull a wire loose?
__________________

__________________
Mark & Carole
What a long strange trip it's been.

No longer RVing. Happy Trails to you.
Campingman is offline   Reply With Quote
Old 09-27-2011, 05:24 AM   #3
Senior Member
 
sdennislee's Avatar


 
Monaco Owners Club
Winnebago Owners Club
Join Date: Sep 2011
Posts: 6,404
Is the lens and cover clear or fogged?
Check for wiring at the camera and possible splices close to camera location, they maybe in the wall, you may have pulled a wire loose.
__________________
US Navy Vet, Liberty Tree Member of Oath Keepers, NRA & VFW Life Member, Alaska EMT.
2009 Safari Cheetah 40 SKQ
2009 Winnebago Chalet 231CR
sdennislee is offline   Reply With Quote
Old 09-28-2011, 10:11 AM   #4
Senior Member
 
SeattlePirat's Avatar
 
Join Date: Nov 2009
Location: Bainbridge Island, Wa
Posts: 453
I spect you pulled the cam cable out of the cable that goes to the monitor. There is likely a 3 or 4 foot cable that plugs into another one that goes up front.
__________________
SeattlePirat is offline   Reply With Quote
Reply

Tags
camera



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Back up Camera Bussman New Member Check-In 2 06-23-2011 09:50 AM
Back up Camera Mr John RV Systems & Appliances 2 06-01-2011 11:01 AM
Back up camera not working JLCHERITAGE MH-General Discussions & Problems 2 05-12-2009 06:36 AM
Back up Camera Rusty Bear Alpine Coach Owner's Forum 2 01-22-2009 06:50 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:11 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.