Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > iRV2.com General Discussion
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 04-18-2015, 10:51 AM   #1
nena's Avatar
Monaco Owners Club
Join Date: Dec 2012
Location: anywhere/everywhere
Posts: 58
Backup Camera

I have a 2012 Monaco Knight.My backup camera has gone blank(screen is black).There is power to the radio.I wonder is there a fuse somewhere are is there another problem.Thanks for any info.

nena is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-18-2015, 12:21 PM   #2
Senior Member
BFlinn181's Avatar

Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 12,641
First thing I'd do is crawl under the dashboard and check all connections are tight and in place. The camera draws such little power, I doubt a fuse blew. Does your camera come on when you put the transmission in reverse? That could be another place for the signal to fail. Also, make sure the display is turned on and contrast turned up.


Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is offline   Reply With Quote
Old 04-28-2015, 05:51 PM   #3
Senior Member
jason1029's Avatar
Join Date: Jul 2013
Posts: 141
The no radio as well as the blank screen could be a blown fuse and or a loose wire issue. You're going to have to check all the fuses and wires. Could be an inline fuse hidden somewhere??

Good Luck!
Jay & Jazz ~ Along The Way With J&J
1994 Tioga - Massachusetts
Follow Us! > Our Blog - YouTube - Twitter - FaceBook
jason1029 is offline   Reply With Quote
Old 04-28-2015, 05:55 PM   #4
Senior Member
Aguyfromcalg's Avatar
Forest River Owners Club
Ford Super Duty Owner
Join Date: Apr 2011
Posts: 859
When mine went black I pushed the reset button with a pen.

2010 Coachmen Freelander 30QB E450 V10
Have Kids Will Travel
Aguyfromcalg is offline   Reply With Quote
Old 04-28-2015, 06:00 PM   #5
Senior Member
Aguyfromcalg's Avatar
Forest River Owners Club
Ford Super Duty Owner
Join Date: Apr 2011
Posts: 859
And did anyone push the off button?

2010 Coachmen Freelander 30qb
Ford E450 V10
2010 Coachmen Freelander 30QB E450 V10
Have Kids Will Travel
Aguyfromcalg is offline   Reply With Quote
Old 04-28-2015, 06:04 PM   #6
Senior Member
brobox's Avatar

Entegra Owners Club
Join Date: Apr 2007
Location: SW FL
Posts: 10,807
Different brand coach, but my BU camera screen also went blank last week. Everything else was working, radio etc. I turned off the 12v power switch..... it re-boot the camera screen and everything is now working fine.

Chuck in SW FL
A "Classic" 2014 Entegra Anthem 42RBQ
2016 Colorado Z71 PU
brobox is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Recommendation for Wireless Backup Camera System RVNewB101 iRV2.com General Discussion 15 05-12-2015 06:24 PM
Backup Camera D-S iRV2.com General Discussion 6 04-30-2015 06:15 PM
Garmin BC 20 Backup Camera O Lloyd Technology: Internet, TV, Satellite, Cell Phones, etc. 0 10-20-2014 06:42 PM
Backup Camera Input Inoperative jpspinks Thor Industries Owner's Forum 7 08-07-2014 07:50 PM
Backup Camera Problem GM28 Class A Motorhome Discussions 7 02-13-2014 08:51 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:10 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.