Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > iRV2.com General Discussion
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 04-06-2012, 09:50 PM   #1
Junior Member
Join Date: Apr 2012
Posts: 1
Engine won't start

Hi! I'm new to the forum and pretty new to my Tiffin Phaeton. We just drove it 700 miles last week. All was fine. Now the engine won't turn over. Not even a click. What might be switched off? Any help appreciated. Single female needs help!

Gail52 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-06-2012, 10:51 PM   #2
Senior Member
Davdeb1's Avatar

Monaco Owners Club
Freightliner Owners Club
iRV2 No Limits Club
Join Date: Jan 2011
Location: Avon Lake, Oh
Posts: 2,788
It's just possible you have a low or dead battery, try getting someone to jump start you.

40 FT--330HP CAT
2 SLIDES-TOAD 2012 focus
Fulltime-Home is where we park it.
Davdeb1 is offline   Reply With Quote
Old 04-07-2012, 12:53 AM   #3
Senior Member
Mr_D's Avatar
iRV2 No Limits Club
Join Date: May 2011
Location: Vancouver, WA
Posts: 22,365
We have a Spartan chassis under our DSDP. At the Phoenix Good Sam rally I pulled in at registration. Stopped the engine and went in to pick up our packet. Tried to start the Ody, the battery was dead so I started the gen set and hooked up the charger. Got it going, got the wife into it and tried to start the MH. Not even a click from the starter. Called CoachNet, they decided it was a dead battery even though I had new batteries (a little over a month old) and they showed 12.48 volts. They dispatched a truck to jump start. After waiting almost two hours I finally called an on site service and cancelled the CoachNet. After several tries they determined that I had either a bad starter, bad starter solenoid or a bad chassis solenoid. Haven't yet figured out which as it's started fine ever since. I did order two of the chassis solenoids as they are only $18 each. They were in stock but haven't arrived yet. Sure hope that cures it as a rebuilt starter (can't get the solenoid from Cummins as a separate part) is close to $400. I'll try the chassis solenoid first, and go from there.
2009 45' Magna 630 w/Cummins ISX 650 HP/1950 Lbs Ft
Charter Good Sam Lifetime Member, FMCA, SKP
RV'ing since 1957, NRA Benefactor Life, towing '05 Odyssey
Mr_D is online now   Reply With Quote
Old 04-07-2012, 06:35 AM   #4
Senior Member
H. Miller's Avatar
Monaco Owners Club
Texas Boomers Club
Join Date: Jan 2009
Posts: 2,516
Different Tiffins manufactured in different years with different engines can have different problems.
Tiffin model?
Engine make & model (horsepower)
Hal & Ginny Miller '04 Beaver Santiam PRT40
'04 Saturn Vue - US Gear Brake - Blue Ox tow
4 "girls" (3 Irish Setters - Retriever)
H. Miller is offline   Reply With Quote

« Chatting | Air bags »

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Power washing engine starts fire! johnnyringo iRV2.com General Discussion 14 04-26-2012 01:52 PM
Onan Generator Marquis Gold - still won't start - how to get carb off? baloo RV Systems & Appliances 7 04-16-2012 08:26 PM
Best Oil for 305-hp 6.8L Super-Duty V10 SEFI Triton® engine Andy-Mo MH-General Discussions & Problems 29 04-10-2012 09:25 AM
Dual air conditioners won't run together aaamarine Class A Motorhome Discussions 2 04-06-2012 02:07 PM
Matching TriMark keys won't turn bay locks aaamarine Country Coach Owners Forum 6 04-06-2012 10:22 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:22 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.