Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > iRV2.com General Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-16-2011, 02:30 PM   #1
Member
 
Join Date: Mar 2011
Posts: 30
Equalizer Jacks

I have equalizer jacks on our 04 Select. Had the jacks checked and the
tech rep said they are okay and not loosing pressure. Rig seems to be pretty stable when we first park, buy after about 20-30 minutes, I hear
creaking and popping sounds near the rear area by the rear jacks. The rig
then seems to be really loose and you can feel a lot of movement when
someone is walking around. Any one else have this problem. Rig is 45 ft and I wonder if the I beams aren't properly braced. I've had "xbracing" done is Elkhart to beef it up, but it hasn't helped.
__________________

__________________
exsailor1 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-16-2011, 03:11 PM   #2
Senior Member
 
billyb's Avatar
 
Join Date: Feb 2002
Location: bel air, md
Posts: 771
it sounds to me like you have air in the system. you might have a low fluid level in the pump resorvoir
__________________

__________________
09 Winnie 32 h adventurer towing 15 focus
billyb is offline   Reply With Quote
Old 03-16-2011, 04:00 PM   #3
Moderator Emeritus
 
Gary RVRoamer's Avatar


 
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 18,066
I had a similar problem with my Equalizers and it turned out the jacks were undersized right from the factory. American Coach upgraded them to the larger size (at their expense) and all was fine thereafter.

I would think your TS Select came with the biggest size to start with, but who knows? Maybe somebody installed the wrong ones?

Have you called Equalizer to discuss the problem? They were helpful to me.
__________________
Gary Brinck
Former owner of 2004 American Tradition
Home is in the Ocala Nat'l Forest near Ocala, FL
Summers in Black Mountain, NC
Gary RVRoamer is online now   Reply With Quote
Old 03-16-2011, 05:19 PM   #4
Member
 
Join Date: Mar 2011
Posts: 30
They are the big jacks. Had them checked out by a Equalizer rep in Elkhart IN and they didn't move overnight, so I'm thinking there is a problem with the frame.
__________________
exsailor1 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HWH Jacks not storing, panel not lit JRS 39K MH-General Discussions & Problems 3 10-12-2010 10:05 AM
Which first..air up or jacks up? IDAHO Jim Monaco Owner's Forum 23 09-16-2010 05:48 PM
Electric or Hydraulic Jacks on Class A?? WesBoy Class A Motorhome Discussions 5 08-09-2010 10:49 AM
Hydraulic jacks vs Air bags won peliaspastia Freightliner Motorhome Chassis Forum 8 12-31-2009 08:58 PM
HWH Jacks working, not working and working again? Bob&Pat Winnebago Industries Owner's Forum 6 06-08-2006 05:22 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:00 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.