Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > iRV2.com General Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-27-2015, 09:19 AM   #1
Junior Member
 
Join Date: Aug 2015
Posts: 7
Front Air Control Question

So we have a 96' Georgie Boy Cruise Master, runs great etc... I have an issue with the front air control that I am hoping someone here has seen before. There are two issues but I have a feeling they are both related.

Problem #1, the lever to change from Hot to Cold, moves just fine, my problem was only hot air was coming out no cold, I have sense then recharged the AC and that's when I realized the problem has to with the valve which opens and close the water line to the heater core, it was open and never closing, I noticed that when I slide it to hot or cold the cable which hooks up to this valve is never moving, now if I manually move it then I get my cold air no problem, just doesn't do it with the controller on the dash.

Problem #2, now this has 4 air control setting, Front, Front / Feet, Feet, and then defrost. The first 3 work fine, I hit the buttons and it will change from upper, to lower, lower and upper, but when I hit defrost nothing changes, it just stays on what ever the prior setting was.

I am guessing this is a electrical issue with both and not a vacuum issue. Ideas on where to start looking for this?

Thanks!


Here is the control for it.
http://www.evanstempcon.com/servicep...ullID=RV218416
__________________

__________________
Sabby is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-27-2015, 10:36 AM   #2
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 16,239
The push buttons on the dash control actually control vacuum. Usually when no vacuum is present, the controller defaults to defroster vents. On a diesel coach the vacuum is provided by an electric vacuum pump, usually on the bulkhead in front of the dash. In a gas RV, the vacuum is provided by the engine.

On the temperature control, if you slide the lever and see no movement in the wire enclosed in the sheath, it's a mechanical issue, not electrical. Wire could be broken or not connected to the lever or the control valve in the heater hose.

The AC is powered by the push button in the upper left corner of the dash control, the LED in the button should come on when pushed in the on position.
__________________

__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is offline   Reply With Quote
Old 08-27-2015, 01:49 PM   #3
Junior Member
 
Join Date: Aug 2015
Posts: 7
Must be a single vacuum line then, 3 out 4 buttons work. Defrost is the one that doesn't work. I'll check to see if the link is broken on the hot and cold from the back of the controller, I can see from the valve that the cable runs to looks good and intact, I bet my problems are all under the dash.
__________________
Sabby is offline   Reply With Quote
Old 08-27-2015, 02:38 PM   #4
Junior Member
 
Join Date: Aug 2015
Posts: 7
For anyone down the road that may run into similar problems with this front air control, I found this Evans site to be very useful. I already know just from reading the troubleshooting guides why I can't got from Hot to Cold and vice versa. Cable, dash side, must have come undone.

Evans Tempcon, Inc
__________________
Sabby is offline   Reply With Quote
Old 08-27-2015, 04:07 PM   #5
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 16,239
The defrost vacuum 'motor' could be bad or as you say, a bad vacuum line. The same dash controller was used in Dodge pick up trucks, mine was bad in my RV and I got a replacement for a fraction of the cost of a new one.
__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is offline   Reply With Quote
Old 08-30-2015, 06:14 PM   #6
Senior Member
 
Join Date: Jan 2008
Location: Big Bear Lake, Ca
Posts: 886
So replace the slide wire from control to valve or replace with a standard manual choke system. As for the other vacuum problem??
__________________

__________________
2004 CRV TOAD/1990 WRANGLER TOAD ROCK BUILT
Forest Grump is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stupid question, just found out dash air is fried Unknown Guy MH-General Discussions & Problems 21 06-24-2015 06:47 AM
Air Con Question Jchet 5th Wheel Discussion 3 05-11-2015 07:49 PM
Front Air Bag Solenoid Reason1 Monaco Owner's Forum 6 08-05-2014 06:15 PM
Air suspension problem, front not airing up... Redridge Palazzo Motorhomes 9 07-09-2014 05:32 AM
Air suspension problem, rear is fine but front is not? Redridge MH-General Discussions & Problems 6 07-06-2014 09:12 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:51 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.