Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > iRV2.com General Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-16-2011, 12:34 PM   #1
Member
 
Workhorse Chassis Owner
Join Date: Sep 2009
Posts: 45
Generator Problem

Our Onan 5500 runs fine under load, usually with roof A/C but when the A/C cycles off, the generator runs for about 10 seconds and shuts down. It will restart but won't keep running unless under the load of the roof A/C. Any suggestions on what to look for?
Thanks,
Dick
__________________

__________________
2002 R-Vision 27Ft
Workhorse P32
Hammerdown is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-17-2011, 10:14 AM   #2
Senior Member
 
pwf16129's Avatar
 
Join Date: Jan 2011
Posts: 267
does it blow any black smoke when it shuts down? if not ch the low speed idle screw possibly backed out, sounds like running on high idle with load governor is keeping speed up or possibly low speed jet is dirty when unloads come back to idle is starving for fuel if black smoke possibly choke is sticking or needle has trash under it?

just my two cents worth good luck
__________________

__________________
pwf16129 is offline   Reply With Quote
Old 07-17-2011, 11:50 AM   #3
Member
 
Workhorse Chassis Owner
Join Date: Sep 2009
Posts: 45
Thanks for the suggestions. I don't see any black smoke, it just stops running like I shut it off.
__________________
2002 R-Vision 27Ft
Workhorse P32
Hammerdown is offline   Reply With Quote
Old 07-17-2011, 12:37 PM   #4
Senior Member
 
Workhorse Chassis Owner
Join Date: Jun 2006
Location: Northwestern Montana
Posts: 3,138
Quote:
Originally Posted by pwf16129 View Post
does it blow any black smoke when it shuts down? if not ch the low speed idle screw possibly backed out, sounds like running on high idle with load governor is keeping speed up or possibly low speed jet is dirty when unloads come back to idle is starving for fuel if black smoke possibly choke is sticking or needle has trash under it?

just my two cents worth good luck
.
That would be my guess also, no low speed circuit for what ever reason, running on governed high speed circuit while under load, engine has no fuel to run on when A/C cycles and removes the load due to low speed circuit being plugged.

Dieselclacker
__________________
dieselclacker is offline   Reply With Quote
Old 07-17-2011, 03:51 PM   #5
Member
 
Workhorse Chassis Owner
Join Date: Sep 2009
Posts: 45
Guess I'll have to find a maintenance or repair manual so I'll know what to play with on the carb. Thanks for your help.
Dick
__________________
2002 R-Vision 27Ft
Workhorse P32
Hammerdown is offline   Reply With Quote
Old 07-17-2011, 04:15 PM   #6
D&J
Member
 
Join Date: Feb 2008
Posts: 69
Quote:
Originally Posted by Hammerdown View Post
Our Onan 5500 runs fine under load, usually with roof A/C but when the A/C cycles off, the generator runs for about 10 seconds and shuts down. It will restart but won't keep running unless under the load of the roof A/C. Any suggestions on what to look for?
Thanks,
Dick
It sounds like you need to remove the carburetor and clean it, I think it's not getting fuel through the primary jet that's used at low load but it's getting fuel from the jet controlled by the governor under heavy load.

Denny
__________________
2013 F350 DRW 6.2 V8 4.30 gears

2003 HH 35 Premier
D&J is offline   Reply With Quote
Old 07-17-2011, 05:45 PM   #7
Senior Member
 
Join Date: Apr 2011
Posts: 120
Have you tried flipping the breakers off on the generator when its cold and starting it up like that?

Chris
__________________
HoRotica is offline   Reply With Quote
Old 07-18-2011, 06:25 PM   #8
Member
 
Workhorse Chassis Owner
Join Date: Sep 2009
Posts: 45
Thanks for your help and direction, here's what worked. Started the generator with the a/c switch on and it ran like it has been. I had removed the air filter cartridge. I shot some choke and carb cleaner in short bursts into the carb, turned off the a/c and shot more cleaner in and it quit in 5-10 seconds. I let it cool for an hour. Started it again with the a/c on, let it run for 5 minutes, shot some brake cleaner in the carb, turned off the a/c and shot more brake cleaner in and that did the trick. It ran with the a/c off for 5 minutes, back on for a couple of minutes and back off again, it kept running at roughly the same speed whether the a/c was on or off. I think I'm back in business.
Thanks again,
Dick
__________________
2002 R-Vision 27Ft
Workhorse P32
Hammerdown is offline   Reply With Quote
Old 07-18-2011, 07:19 PM   #9
Senior Member
 
ronspradley's Avatar


 
Gulf Streamers Club
Join Date: Mar 2011
Location: Central Texas
Posts: 1,623
I do not understand using brake cleaner on carb? Why brake cleaner and not carb cleaner? I do not want to question success, but what is up with the brake cleaner? ronspradley
__________________
1993 Gulfstream Sun Voyager DP 30'
200 HP Cummins B5.9, 4sp Allison AT542
Toad 1998 Honda CRV, 2006 Honda CRV
Life's too short to drink cheap beer.
ronspradley is online now   Reply With Quote
Old 07-18-2011, 09:10 PM   #10
Member
 
Workhorse Chassis Owner
Join Date: Sep 2009
Posts: 45
Brake cleaner seemed to dissolve the gunk quicker and it evaporates faster. I used carb cleaner first.
__________________

__________________
2002 R-Vision 27Ft
Workhorse P32
Hammerdown is offline   Reply With Quote
Reply

Tags
generator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:57 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.