Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > iRV2.com General Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-10-2015, 11:09 PM   #1
Member
 
Join Date: Mar 2014
Posts: 34
Help with battery monitor wiring.

Hey guys I bought a Xantrex linklite battery monitor. And I'm have trouble getting any readings. . The monitor powers on and reals volts. But the amp hours and amps used is 0. I'm beginning to think I might have my battery bank hooked up wrong so it's bypassing the shunt or something. Here is a very bad drawing.... if it's wrong a new drawing would be nice. My battery's are 12 volt. Also I have 3 sets of wires going to my battery housing g so I just assumed they are from the generator, battery charger, and the rv.
The rig is a 06 forrest river Salem toyhauler Thanks guys!
Attached Thumbnails
Click image for larger version

Name:	1433995624436.jpg
Views:	69
Size:	49.4 KB
ID:	96895  
__________________

__________________
MitchellPnw is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-11-2015, 08:10 AM   #2
Registered User
 
Join Date: Sep 2014
Posts: 2,312
I couldn't really see anything hooked up wrong from your picture. (disclaimer; I have a different type of meter)

I'm curious if the coach has another ground source going to the batteries. Are you sure the only connection to the batteries is through the black cable going to the shunt.

Good luck!
__________________

__________________
okcnewbie is offline   Reply With Quote
Old 06-11-2015, 11:59 AM   #3
Senior Member
 
Join Date: Mar 2013
Posts: 304
You are only showing 2 wires from the shunt. You should have a ground wire from the negative to supply the - to run the meter and then a twisted set from the 2 small screws in the center of the shunt and the shunt terminals on your meter.
__________________
MotorPro is offline   Reply With Quote
Old 06-11-2015, 02:27 PM   #4
Moderator Emeritus
 
Gary RVRoamer's Avatar


 
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 18,073
In other such systems I've seen, the shunt should be between the batteries and chassis ground. I can't tell if that is the case from your diagram - is that what the "RV" in the picture means? If the battery bank has any other pathway to ground, the shunt will show nothing or incorrect amps.
__________________
Gary Brinck
Former owner of 2004 American Tradition
Home is in the Ocala Nat'l Forest near Ocala, FL
Summers in Black Mountain, NC
Gary RVRoamer is offline   Reply With Quote
Old 06-19-2015, 08:35 AM   #5
Junior Member
 
Paradox1's Avatar
 
Join Date: Mar 2015
Location: Upstate New York
Posts: 28
It is important the wires from the monitor are hooked up to the shunt in the correct manner. Check the installation manual against the wiring.
Ed
__________________
Paradox1 is offline   Reply With Quote
Reply

Tags
battery, wiring



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Large power draw on chassis battery '94 Kountry Star omegacanuck Newmar Owner's Forum 54 01-31-2016 09:22 PM
Battery Tray: Not a Mod, Just a Cleanup JFXG Newmar Owner's Forum 21 12-01-2014 07:33 AM
Chassis Battery Issue TXBart Entegra Owner's Forum 35 11-03-2014 04:48 PM
Help Diagnosing Battery Isolator Relay RustyTravelr Class A Motorhome Discussions 13 09-06-2014 08:59 PM
Battery Control Center Problems jbrinsfi RV Systems & Appliances 9 05-26-2014 03:08 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:32 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.