Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > iRV2.com General Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-02-2015, 10:00 AM   #1
Junior Member
 
Join Date: Jun 2015
Posts: 2
New To us

Just purchased a coachman catalina 23 ft travel travel. My wife has painted the outside made some new curtains. We put a futon in the front bedroom for us. The back room will be for our 13 year old and the two little ones can sleep on the fold down table. All the lights where working on this towable a week ago but now the bathroom lights do not work and the left turn signal does not work. Would love to have some help with this any ideas would be great. We have checked the fuses and they are ok.
__________________

__________________
helomech45 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-02-2015, 11:49 AM   #2
Community Administrator
 
JohnRR's Avatar


 
Fleetwood Owners Club
Workhorse Chassis Owner
Join Date: Sep 2010
Location: Marquette, Michigan "Da UP"
Posts: 16,940

Good luck with a solution.
__________________

__________________
John & Cathy R.
06 Pace Arrow 38L W24
08 14 Lincoln MKX AWD
See My RV Upgrades
JohnRR is offline   Reply With Quote
Old 06-02-2015, 04:27 PM   #3
Senior Member
 
denlock's Avatar
 
Newmar Owners Club
Spartan Chassis
Join Date: Feb 2005
Location: Sterling Heights, MI
Posts: 2,723


Check your ground wires. Make sure the connection is clean and tight.
__________________
Tricia & Dennis Lockhart
2010 Ventana 4333
Spartan MM w/Cummins 360 ISC
denlock is offline   Reply With Quote
Old 06-02-2015, 06:14 PM   #4
Senior Member
 
hal1phx's Avatar


 
Join Date: Aug 2013
Location: Everywhere USA
Posts: 2,072
__________________
Hal & Jackie .... 03 TS Select 45DS01
02 Haulmark 20' Edge .... 02 Corvette Rdstr


Our Blog
hal1phx is offline   Reply With Quote
Old 06-03-2015, 07:26 AM   #5
Senior Member
 
Country Coach Owners Club
Retired Fire Service RVer's
Join Date: Feb 2013
Location: Ocala, Florida
Posts: 6,295
Welcome, glad to meet you!
__________________
FMCA #F431170, GS #822128658, Escapees SKP #112655
2012 Airstream Mercedes Interstate Class B
[SIGPIC][/SIGPIC]
Medico is offline   Reply With Quote
Old 06-03-2015, 11:58 AM   #6
Senior Member/RVM #90
 
MSHappyCampers's Avatar


 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 26,295
Welcome to IRV2! We're sure glad you joined us!

Congrats on the new rig! Keep her between the ditches!

Good luck, happy trails, and God bless!
__________________
Joe & Annette

2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is offline   Reply With Quote
Old 06-03-2015, 12:16 PM   #7
Senior Member
 
scenic route's Avatar
 
Join Date: Jan 2010
Posts: 1,767
The light problem may possibly be a remote GFI (Ground Fault Isolation) that has popped and needs a reset. Not familiar with your unit, try checking under the bathroom sink area or it could be located on the BR wall or in a closet nearby.



https://www.google.com/search?q=pict...ml%3B300%3B300
__________________
scenic route is offline   Reply With Quote
Old 06-04-2015, 05:12 PM   #8
Senior Member
 
jason1029's Avatar
 
Join Date: Jul 2013
Posts: 141
Congrats! and Welcome! Have fun!
__________________
Jay & Jazz ~ Along The Way With J&J
1994 Tioga - Massachusetts
Follow Us! > Our Blog - YouTube - Twitter - FaceBook
jason1029 is offline   Reply With Quote
Old 06-04-2015, 07:21 PM   #9
Senior Member
 
OLYLEN's Avatar
 
Monaco Owners Club
Join Date: Jan 2008
Location: Olympia, Wa
Posts: 2,335
I would bet the bathroom lights are 12 volt not 120 volt so if fuse is good it either the switch or the bulb or power coming in + or -. As for the blinker, if you have the blinker on the tow rig then it is either the bulb or the connection somewhere along the way.

LEN
__________________

__________________
2004 Clss C 31' Winnebgo
OLYLEN is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:16 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.