Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > iRV2.com General Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-11-2011, 09:25 PM   #1
Senior Member
 
ftv37's Avatar
 
Join Date: Mar 2010
Location: Richland,Or
Posts: 101
Oh Man :(

Getting our 86 Ellandan 28footer ready for our trip this wednesday and was doing some work on the coach battery system hit the positive side on frame.
So today I started the genny and it ran for about 3 min and died
Then no start

It did the same thing when we first got it,turned out to be the control board.
So I ordered a new one from Flight Systems,should be here Tuesday.Probably
shorted the board out,glad it happened at home.Just had to vent
__________________

__________________
ftv37 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-11-2011, 09:41 PM   #2
Senior Member
 
Join Date: Jan 2010
Location: Okanagan valley British Columbia
Posts: 707
Now you know why to disconnect the ground cable first.
__________________

__________________
RoyM is offline   Reply With Quote
Old 06-11-2011, 09:53 PM   #3
Senior Member
 
ftv37's Avatar
 
Join Date: Mar 2010
Location: Richland,Or
Posts: 101
I know: Couldn't tell you why it went out the first time,they told me because it sat for so long the components on the board dried out and went bad. Thats what I get for rushing
__________________
ftv37 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Crabby old man rmmpe Just Conversation 8 12-02-2010 10:13 AM
Burning Man Bound (AKA Kamikaze Mission) PlayaHoney New Member Check-In 2 08-01-2010 03:15 AM
A real one man brake bleeder inspectorudy Winnebago Industries Owner's Forum 4 05-06-2010 12:29 PM
Seajay the sailor man Seajay Military / Veteran RVing 29 03-06-2010 07:28 PM
Last Words of a Dying Man HuBee RV'ing Humor & Crazy but True Stories 2 06-21-2008 06:51 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:51 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.