Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > iRV2.com General Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-08-2011, 11:15 AM   #1
Junior Member
 
Join Date: Jun 2011
Posts: 1
Open Range RV

Hello, My husband and I have owned our 2010 399BHS for 14 months now. When we first picked it up the outer doors were not right, which took two months for them to finally fix, after contacting the company and having them get involved. Now, we went to open the camper from having it winterized, while cleaning it up and getting ready for our trip next month, I found mold growing in the back bunkhouse on the center wardrobe (inside the cabinet and outside) on the bottom, carpet and padding and it even looks like it's going into the vent on the floor. My husband and I hooked the camper up and took it to the dealer on Sunday, I called on Monday and the warranty person told me they would get to when they could get to it. I understand they are busy, but that's not what someone wants to hear. So I contact Pam Graber, Randy's wife, and she sent my email to Ron Howard in charge of warranty, which he is great he got our door situation taken care of, he said he left a message for the owner of the dealership to take pictures and email him ASAP. I haven't heard anything since Monday, which I will give them till Friday and I will be making some calls. But I was just wondering if anyone else had any issues with mold growing in their Open Range camper....We really researched on buying our first 5th wheel went to numerous camper shows and fell in love with the Open Range, I know you have issues with campers, but when you spend the money you do, you want it to work right and not have issues right away. Thanks for letting me vent, my problem. If anyone can give us any advice please let us know.
__________________

__________________
AnimalHouse is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-10-2011, 07:20 PM   #2
Senior Member
 
Dixieray53's Avatar
 
Thor Owners Club
Join Date: Dec 2010
Location: Belmont NC
Posts: 1,320
Blog Entries: 1
First Welcome to the forum.. Sorry for your troulble. The mold grew during the winter . Was there a leak in a slide? Hang in there..The dumps make the smooth parts all the better .Peace and Safe Travels D
__________________

__________________
Dickson and Tracy
2016 Thor Windsport 31S
2015 Fusion Titanium Hybrid
Lemon and Tucker the Pups
Dixieray53 is offline   Reply With Quote
Old 10-16-2011, 07:56 AM   #3
Member
 
Cartist's Avatar
 
Join Date: Sep 2010
Posts: 66
Open Range

Quote:
Originally Posted by AnimalHouse View Post
Hello, My husband and I have owned our 2010 399BHS for 14 months now. When we first picked it up the outer doors were not right, which took two months for them to finally fix, after contacting the company and having them get involved. Now, we went to open the camper from having it winterized, while cleaning it up and getting ready for our trip next month, I found mold growing in the back bunkhouse on the center wardrobe (inside the cabinet and outside) on the bottom, carpet and padding and it even looks like it's going into the vent on the floor. My husband and I hooked the camper up and took it to the dealer on Sunday, I called on Monday and the warranty person told me they would get to when they could get to it. I understand they are busy, but that's not what someone wants to hear. So I contact Pam Graber, Randy's wife, and she sent my email to Ron Howard in charge of warranty, which he is great he got our door situation taken care of, he said he left a message for the owner of the dealership to take pictures and email him ASAP. I haven't heard anything since Monday, which I will give them till Friday and I will be making some calls. But I was just wondering if anyone else had any issues with mold growing in their Open Range camper....We really researched on buying our first 5th wheel went to numerous camper shows and fell in love with the Open Range, I know you have issues with campers, but when you spend the money you do, you want it to work right and not have issues right away. Thanks for letting me vent, my problem. If anyone can give us any advice please let us know.
I think Open Range has a lot of issue's, the first one is: They make a beautiful rv fiver, but cannot say much about the workmanship. When our OR arrive, we did several walk threw, but when we got it home we did several more, their were many problems with the OR as far as workmanship, the biggest problem. We are still having some issues, but hope to get it resolved.
It does pull like a dream. Just stick to your guns and keep at them until they get it right, even if you have to take it back to the factory direct. Just get everything done before the warranty runs out.
You can email me privately if you wish.
Rob/Coni
__________________
Cartist is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Black tank valve open!?!?!? lp5151 RV Systems & Appliances 12 04-29-2010 01:00 PM
Bed stuck open Hansville Monaco Owner's Forum 6 04-23-2010 06:24 AM
How good is load range E? R1Kirby Class C Motorhome Discussions 7 04-18-2010 09:49 AM
RV Park Now Open at Brazelís DriVer RV Industry Press 5 05-21-2009 08:07 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:04 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.