Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > iRV2.com General Discussion
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 12-08-2011, 10:36 AM   #1
Senior Member
catonine's Avatar
Fleetwood Owners Club
Join Date: Apr 2009
Posts: 413
Power Gear leveler problem

I have a 2006 Monaco Monarch 30PDD with hydrolic PowerGEar levelers, and touchpad 500269. When I went to level the MH the left, right and center lights were flashing when leveling completed. This was in the auto mode. My wife advised that the right rear leveler did not come all the way down. I then put it in manual mode and the jack when down as it should. I retracted the jacks and tried again with same results. I checked the PG troubleshooting guide on their website and did all the things I could that was lsited with no results. Any suggestions on what I need to do next? Thanks for any and all help.

John- 2011 Fleetwood Southwind 32V
catonine is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-08-2011, 12:18 PM   #2
Senior Member
catonine's Avatar
Fleetwood Owners Club
Join Date: Apr 2009
Posts: 413
Problem resolved! I contacted PowerGear and in a few minutes a nice fellow named Tony got back with me. He offered several suggestions to resolve the issue. Prior to the problem popping up I had just finished servicing the levelers, lubing rods etc.. Tony advised me to recheck all connections. I had already done this but went back and did it again just to be safe. I even re-lubed the rods and checked the levels, the whole 9 yards. Behold, I pressed the auto mode button and the levelers worked like a champ. I have no clue what i may have done to rectify the problem, but it is now fully operational. Tony got back with me with other things to try right after this and I told him that all was well. I have PowerGear levelers in other MH's and never had a problem until this one and I have been using these for about 5 years hassel free, so either they make a good product or I am lucky. It has been very cold here this morning and that may have caused the problem with fluid getting thicker, but I dont know. But since it is now about 40 degrees warmer it may have influenced the levelers. Any way, good to know PowerGear responds promtly.

John- 2011 Fleetwood Southwind 32V
catonine is offline   Reply With Quote
Old 12-08-2011, 06:43 PM   #3
Senior Member
Gadget Man's Avatar

Fleetwood Owners Club
Freightliner Owners Club
Join Date: Nov 2001
Location: Southern California
Posts: 1,995
Glad you figured it out.

Same thing happened to me about two years ago. I retracted the jacks, toggled the power and all was well the second time I deployed them. Some sort of a glitch, but it has only happened once in the 5 years that I've owned the coach.

2005 Fleetwood Providence 39J
CAT C7 350, MP-8 Programmer

My wife does all the driving - I just hold the wheel...
Gadget Man is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Gear vs HWH slide/jack mechanisms bdc278 Winnebago Industries Owner's Forum 10 11-02-2011 04:31 PM
Power Gear Seal Replacement Kit Volunteer MH-General Discussions & Problems 11 05-05-2010 12:18 PM
Power Gear Leveler Flashing Lights TurtleBack MH-General Discussions & Problems 5 02-08-2010 04:51 PM
Power Gear Jack Retraction Problem gtcoatie Fleetwood Products Owner's Forum 4 08-15-2008 04:21 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:01 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.