Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > iRV2.com General Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-08-2013, 01:56 PM   #1
Junior Member
 
Holiday Rambler Owners Club
Join Date: Dec 2013
Posts: 14
Question Sensor/switch not working

WE recently purchased a 1997 Holiday rambler Imperial.There are indicator lights on the dash showing when the antenna is up or the compartment doors under the slide-out are up but they don't work. I have located switches/sensors in those locations. They are about 2" long, 1/2" diameter,with 2 wires. Does anyone know what these are called and where I can buy replacements
__________________

__________________
jrburch1946 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-08-2013, 04:04 PM   #2
Senior Member
 
Join Date: May 2004
Location: MI
Posts: 197
My antenna has a mercury tilt switch. There is nothing on my compartment doors but the same type of switch would work there.

It's really rare for them to fail, they just 2 contacts with a ball of mercury which shorts them when turned the right direction. If none of them work I would check voltage to them or ground if that is common. It just doesn't seem likely all of them failed.
__________________

__________________
Argosy is offline   Reply With Quote
Old 12-08-2013, 04:19 PM   #3
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 26,766
Welcome to irv2.
One of our sponsors carries these type may help you.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans, now in good hands
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 12-12-2013, 08:41 PM   #4
Junior Member
 
Holiday Rambler Owners Club
Join Date: Dec 2013
Posts: 14
Smile mercury tilt switches

Thank you very much, they are indeed mercury tilt switches and they were not all bad, a fuse had been partially pulled out. Only one was bad.
__________________
jrburch1946 is offline   Reply With Quote
Old 12-13-2013, 05:41 AM   #5
Senior Member
 
Join Date: May 2004
Location: MI
Posts: 197
Ya gotta love it when it's an easy fix.
__________________
Argosy is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:33 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.