Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > iRV2.com General Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-22-2015, 08:37 PM   #1
Senior Member
 
Mrfoto's Avatar
 
Winnebago Owners Club
Join Date: Aug 2012
Location: Danville VA
Posts: 236
Tripping GFI

At home and trying to hook up for electric, as I have done before with 30 amp coach, but GFI trips with 50 amp plug and adapter on new 50 amp coach. By process of elemination, I unhooked coach and checked just 50 amp surge protector, adapter, and heavy 25 ft extension cord. It trips without anything drawing except surge protector. So I assume it is extension cord. Get different extention cord and same thing, it tripped. So I tried just Tbone adapter and surge protector and no problem, surge protector lights up green. What am I doing wrong? Or will extention cords not work with 50 amp surge protector?
__________________

__________________
Paul & Carol plus 2 Bichons
2015 Winnebago Sightseer 35G, Blue Ox Tiger TracBar, 5 Star tune, Safe-t-plus steering
2008 HHR Toad & Working hard at retirement
Mrfoto is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-22-2015, 09:15 PM   #2
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 14,970
My first two RV's wouldn't trip a GFIC outlet when plugged in , my last two do.

Give this a try , friend with similar issues , talked me into this .
Re-set the GFIC outlet with the coach plugged in to the outlet, works at his house every time I visit.


I have a 50 amp hardwire surge guard and I adapt to his 15 amp GFIC.
__________________

__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 06-22-2015, 10:01 PM   #3
Senior Member
 
Mrfoto's Avatar
 
Winnebago Owners Club
Join Date: Aug 2012
Location: Danville VA
Posts: 236
Skip426, If I try to do the reset on GFI, the surge protector does a 3 minute analysis before kicking on, and that is when it trips the GFI and surge protector both. So I can not get past that point. Strange!
__________________
Paul & Carol plus 2 Bichons
2015 Winnebago Sightseer 35G, Blue Ox Tiger TracBar, 5 Star tune, Safe-t-plus steering
2008 HHR Toad & Working hard at retirement
Mrfoto is offline   Reply With Quote
Old 06-22-2015, 10:19 PM   #4
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 14,970
Probably the power surge , through the protector, when the internal relays click on. Could you try turning off the main breakers in the coach panel, waiting till the surge protector engages then turning the breaker on .
Or may be you need to do what I've had to do at home , extension cord under the garage door to a non-GFIC outlet.
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 06-23-2015, 10:02 PM   #5
Senior Member
 
Mrfoto's Avatar
 
Winnebago Owners Club
Join Date: Aug 2012
Location: Danville VA
Posts: 236
There is nothing plugged into the surge protector and both GFI and surge protector trip! I am thinking it may be time to have electrician wire in 50 amp rv outlet on a dedicated line.
__________________
Paul & Carol plus 2 Bichons
2015 Winnebago Sightseer 35G, Blue Ox Tiger TracBar, 5 Star tune, Safe-t-plus steering
2008 HHR Toad & Working hard at retirement
Mrfoto is offline   Reply With Quote
Old 06-23-2015, 11:15 PM   #6
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 14,970
The ultimate fix.
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 06-24-2015, 06:15 PM   #7
Moderator Emeritus
 
Gary RVRoamer's Avatar


 
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 18,073
It sounds as though the Surge Guard might be sending a bit of current to the ground pin during its analysis. That would trip any GFCI, every time. I didn't think they would do that, so maybe call Surge Guard (TRC) and ask about it. I don't recall that my Surge Guard #40250 does that, but may not have tried it with a 15A GFCI outlet.

What is the indication on the Surge Guard when it "trips"? If the GFCI outlet isn't wired properly, most anything could happen.
__________________

__________________
Gary Brinck
Former owner of 2004 American Tradition
Home is in the Ocala Nat'l Forest near Ocala, FL
Summers in Black Mountain, NC
Gary RVRoamer is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GFI tripping, with inverter and transfer switch pokgunner RV Systems & Appliances 4 05-30-2015 03:50 PM
Bathroom GFI Plug in on my 99 Diplomat md99 Monaco Owner's Forum 13 05-05-2015 07:41 AM
84' Holiday Rambler, Need help locating GFI Gump Vintage RV's 10 01-24-2015 11:44 PM
Power Loss All GFI Outlets sdcyclist Alpine Coach Owner's Forum 3 10-20-2014 03:08 PM
BUZZZZZ went the GFI pumper9x9 Country Coach Owners Forum 2 02-23-2014 11:15 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:39 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.