Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > iRV2.com General Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-30-2015, 05:05 PM   #1
Member
 
Ford Super Duty Owner
Join Date: Aug 2011
Location: Eastern Ohio
Posts: 40
Water pump loses prim

My 12 v. water pump keeps losing it's prim. Pump runs fine but after sitting for a while won't pump water. If I hook up to city water and force water through the pump it will work fine until it sits a while again. No leaks, good pressure. help please
__________________

__________________
redtop is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-30-2015, 07:18 PM   #2
Senior Member
 
Ray,IN's Avatar
 
Join Date: Aug 2001
Location: North America somewhere
Posts: 13,709
I suspect a bad diaphragm.They are easy to replace, not costly. just make sure the screws are tight. Humm, have you checked if your screws are tight now?
__________________

__________________
2000 Winnebago Ultimate Freedom USQ40JD, ISC 8.3 Cummins 350, Spartan MM Chassis. USA 1SG, retired;PPA,Good Sam Life member,FMCA."We the people are the rightful masters of both the Congress and the Courts - not to overthrow the Constitution but to overthrow men who pervert the Constitution. "Abraham Lincoln"
Ray,IN is offline   Reply With Quote
Old 04-30-2015, 08:15 PM   #3
Junior Member
 
ronsteward's Avatar


 
Monaco Owners Club
Join Date: Nov 2014
Location: Oak Ridge, TN
Posts: 20
Blog Entries: 1
Mine was running a long time, not much pressure and took a long time to get started but it didn't leak water but I could hear it sucking air. Took it down to replace it and found it had O rings in the pipes going into and out of it. Replaced the 10 cent O rings and it works perfect.
Hope this helps.
__________________
ronsteward is offline   Reply With Quote
Reply

Tags
water, water pump



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with water pump problem please VB Bill Entegra Owner's Forum 18 02-20-2015 08:51 PM
Water Pump Light in Utility Area rockintom Excel Owner's Forum 2 10-03-2014 06:37 PM
Macerator or Water Pump - need recommendation Nunyadamn RV Systems & Appliances 2 06-16-2014 07:56 PM
How to prime water pump? bluelghttr National RV Owner's Forum 5 05-13-2014 06:44 PM
Water Pump Relay Location Sohapi Monaco Owner's Forum 15 03-08-2014 12:17 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:57 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.