Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > iRV2.com General Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-06-2012, 12:56 PM   #1
Member
 
Brake-less's Avatar
 
Workhorse Chassis Owner
Join Date: May 2008
Location: Crawfordville, FL
Posts: 76
weatherpro power awning

HELP!!!!! Weatherpro power awning will not open. Fuse OK. Can hear click with panel button and remote button. Just hear click. No movement of awning.Voltage good. Could the motor be locked up?
__________________

__________________
2004 Coachman Santara
W22
Brake-less is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-06-2012, 01:26 PM   #2
Senior Member
 
scenic route's Avatar
 
Join Date: Jan 2010
Posts: 1,767
Quote:
Originally Posted by Brake-less View Post
HELP!!!!! Weatherpro power awning will not open. Fuse OK. Can hear click with panel button and remote button. Just hear click. No movement of awning.Voltage good. Could the motor be locked up?
Could be...could be the tube drive cup at the motor has rounded out around the shaft. This happened to us, only in the down position.

More than likely, it's an electrical problem. I'd suggest taking off the motor cover and checking for power. It might be easier to get access to the awning switch contacts to see if you've got power at the switch and out of the switch first. Volt/ohm meters or the simple trouble light are most handy chasing down electrons. Bob
__________________

__________________
Jan and Bob

RIP 'Squeaky'
scenic route is offline   Reply With Quote
Old 03-06-2012, 01:34 PM   #3
Member
 
ZephyrKnight's Avatar
 
Tiffin Owners Club
Join Date: Jul 2010
Posts: 47
It was for us...same exact thing....and it was actually due to corrosion. Fortunately I was able to free it up by power blasting it with Corrosion X and letting it sit awhile. A few more attempts and presto...it started working again. During the troubleshooting period, I did manage to find out from their reps that this is common where the "elements" can get in to the motor area...and I did find where the water was able to get into the covered area. My guess is you have water intrusion in that area as well. Good Luck
__________________
Bob & Melissa
2005 Tiffin Zephyr
Traveling with the kids (w/fur)
ZephyrKnight is offline   Reply With Quote
Old 03-06-2012, 03:29 PM   #4
Member
 
Brake-less's Avatar
 
Workhorse Chassis Owner
Join Date: May 2008
Location: Crawfordville, FL
Posts: 76
Thanks for the info. How did you get to the motor to spray it?
__________________
2004 Coachman Santara
W22
Brake-less is offline   Reply With Quote
Old 03-09-2012, 10:32 AM   #5
Senior Member
 
scenic route's Avatar
 
Join Date: Jan 2010
Posts: 1,767
Here is a site that might help...if you haven't already found it. Bob
__________________
Jan and Bob

RIP 'Squeaky'
scenic route is offline   Reply With Quote
Old 03-09-2012, 03:54 PM   #6
Member
 
ZephyrKnight's Avatar
 
Tiffin Owners Club
Join Date: Jul 2010
Posts: 47
My bad - The wife reminded me that it was our door awning that was stuck...and we blasted (covered area completely) with the Corrosion X... In the door everything is pretty much right there and available, so using that straw attachment we could spay into all the little cracks and crevases. Sorry to say, i was using the Corrosion X in that manner to prove a friend wrong...and he won. He is the one that got me "believing" in the Corrosion X...it won't hurt electronics. He went to some demo where they had a radio, or some type of electonics, virtually emersed in this stuff and it was working...and i wasn't believing his story...but it did free the door awning. i mean it had to be the Corrosion X - because that was all i did. I hope you're as fortunate with your results on the big awning.

My big awning works...but the wind sensor just "beeps"...and i haven't had time to troubleshoot that one. The info provided with the weather pro manual is the same info i have - hope that helps as well.
__________________
Bob & Melissa
2005 Tiffin Zephyr
Traveling with the kids (w/fur)
ZephyrKnight is offline   Reply With Quote
Old 03-09-2012, 04:44 PM   #7
Senior Member
 
jzick's Avatar
 
Join Date: Feb 2007
Location: Florida
Posts: 1,193
Our Weatherpro awning is 5 years old. Every year in the five we have had the same symptoms (motor overheats, clicks when switch activated, then cools and will move a few inches more). The fixes have been to adjust the spring, adjust the fabric, lubricate the move points, seal the motor to keep the rain out, and the last fix has been to replace the motor. Note. If you are going to try to adjust the spring yourself, be very careful. A tech who did ours ended up with a broken hand when he made a mistake and did not secure the spring good enough.

Lucky for us, we have an extended warranty that has paid for all these repairs and each time it has worked well for the entire length of our trip (6-7 months). It has not been, however, a piece of equipment that I would recommend. Next coach will have another brand.
__________________

__________________
jzick is offline   Reply With Quote
Reply

Tags
awning, power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Progressive Industries RV Power Protection SSteve iRV2.com General Discussion 67 06-11-2012 04:45 PM
No power to kitchen sink light Bruce and Jenna Excel Owner's Forum 27 03-21-2012 08:36 PM
workhorse chassis noise: sounds like power steering pump sheriwduchar Workhorse and Chevrolet Chassis Motorhome Forum 8 03-10-2012 09:20 AM
Loss of power palebiker Monaco Owner's Forum 5 03-06-2012 08:38 PM
Pop Up Power Roof System 3kids5 Pop Up, Tent Trailer and Teardrop Topics 1 03-05-2012 07:18 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:15 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.