Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > iRV2.com General Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-24-2014, 07:22 AM   #1
Junior Member
 
Join Date: Mar 2014
Posts: 6
Windshield | Screen Washer Pump

Hi all,

Could any body please help, I own a holiday rambler arista 2008 model year,
up until last week my screen wash pump did work and now its not

I have done several tests and i have no power to the wires in which connects to the pump
when i twist the stalk the wiper work but no power to the screen wash pump, i have checked all fuses and are all good.

would it be the indicator stalk now faulty ???

Also what i would like is a wire diagram for my rv is there any body out there who could email me this or could tell me on how i could download this wiring diagram ?
thank you to all that can help me.
Jason Kent from England united kingdom
__________________

__________________
jkent19 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-24-2014, 10:00 PM   #2
Senior Member
 
Ray,IN's Avatar
 
Join Date: Aug 2001
Location: North America somewhere
Posts: 13,712


Sounds like a blown fuse. Locate the chassis fuse panel and look for the windscreen/windshield fuse. If the pump failed it may have also blown the fuse. The pump may be tested with a small 12V battery and a set of test leads/wires if the coach batteries are not nearby.
__________________

__________________
2000 Winnebago Ultimate Freedom USQ40JD, ISC 8.3 Cummins 350, Spartan MM Chassis. USA 1SG, retired;PPA,Good Sam Life member,FMCA."We the people are the rightful masters of both the Congress and the Courts - not to overthrow the Constitution but to overthrow men who pervert the Constitution. "Abraham Lincoln"
Ray,IN is offline   Reply With Quote
Old 03-25-2014, 01:34 AM   #3
Junior Member
 
Join Date: Mar 2014
Posts: 6
Hi all fuses are ok and I have done a test with a small battery and the pump does work then also got a spare pump which does work, but when connected to the harness it does not then work
THANK YOU JASON.
__________________
jkent19 is offline   Reply With Quote
Old 03-25-2014, 04:31 AM   #4
Member
 
Join Date: Mar 2014
Posts: 65
Have you checked the plug for power and earth, ie which is missing?
__________________
Si, Sarah and Shelby the westie
2008 Damon Daybreak 3070
98 TJ, 4" lift, 31s, usual stuff
Dodgey is offline   Reply With Quote
Old 03-25-2014, 07:20 AM   #5
Junior Member
 
Join Date: Mar 2014
Posts: 6
Quote:
Originally Posted by Dodgey View Post
Have you checked the plug for power and earth, ie which is missing?
Hi,
not checked that, but i have disconnected the plug in the engine bay, and i then did not have no power the the wipers so i know i have the right plug.
__________________
jkent19 is offline   Reply With Quote
Reply

Tags
scr



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windshield wiper and washer jjtjr Ford Motorhome Chassis Forum 20 07-04-2014 05:46 AM
Junior member seeks windshield washer info Tleader51 Freightliner Motorhome Chassis Forum 13 03-30-2014 02:49 PM
Windshield screen Rog1965char Newmar Owner's Forum 3 03-21-2014 12:00 AM
screen wash pump jkent19 Monaco Owner's Forum 1 03-18-2014 12:18 PM
Screen wash pump jkent19 Class A Motorhome Discussions 0 03-17-2014 01:58 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:00 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.