Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > iRV2.com General Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-26-2015, 10:34 AM   #1
Junior Member
 
Join Date: Nov 2011
Posts: 3
Wipers

We have a 2003 revolution. It has the smart wheel which has all the controls for wipers. The wipers when plugged in run all the time. Unplug and plug back they are off but you hit on and can't turn off. We have replaced the master box, switch and the circuit board under horn.. This is the PC series. Any idea Thanks Goldie
__________________

__________________
bullock2 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-26-2015, 05:49 PM   #2
Senior Member
 
plasma800's Avatar
 
Fleetwood Owners Club
Join Date: Nov 2013
Location: Houston, Texas
Posts: 3,198
Blog Entries: 1
You might consider reposting this question in a new post in the following forum, with the following title

Fleetwood Products Owner's Forum - iRV2 Forums

TITLE: 03 Revolution wipers won't turn off!!!??
__________________

__________________
RVM#78 - -USAF- F-15 Eagle Radar Vet
'05 Fleetwood Revolution '12 Chevy 2500 '15 Airstream Intl Sig. 27FB
'14 Ram 3500 Aisin
plasma800 is offline   Reply With Quote
Old 06-27-2015, 05:43 PM   #3
Senior Member
 
plasma800's Avatar
 
Fleetwood Owners Club
Join Date: Nov 2013
Location: Houston, Texas
Posts: 3,198
Blog Entries: 1
I retract that statement - Contact Nlovinit iRV2 Forums - View Profile: NLOVNIT and she can retitle and move your post for you.
__________________
RVM#78 - -USAF- F-15 Eagle Radar Vet
'05 Fleetwood Revolution '12 Chevy 2500 '15 Airstream Intl Sig. 27FB
'14 Ram 3500 Aisin
plasma800 is offline   Reply With Quote
Old 06-29-2015, 07:47 AM   #4
Moderator Emeritus
 
Gary RVRoamer's Avatar


 
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 18,073
About the only thing left in the Smart Wheel controls is the wiring harness that runs up through the steering wheel. There have been cases of shorted harnesses that give weird problems such as you are experiencing.
__________________
Gary Brinck
Former owner of 2004 American Tradition
Home is in the Ocala Nat'l Forest near Ocala, FL
Summers in Black Mountain, NC
Gary RVRoamer is offline   Reply With Quote
Old 06-29-2015, 08:17 AM   #5
Senior Member
 
denlock's Avatar
 
Newmar Owners Club
Spartan Chassis
Join Date: Feb 2005
Location: Sterling Heights, MI
Posts: 2,723


Good luck with a solution. I had the same problem on a Pace Arrow on a Workhorse chassis. We were out in the cold and just went away after it warmed up.
__________________
Tricia & Dennis Lockhart
2010 Ventana 4333
Spartan MM w/Cummins 360 ISC
denlock is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Smart Wheel 5A fuse failure...Wipers run amuck! SaguaroBob Country Coach Owners Forum 3 05-24-2015 09:48 PM
Windshield Wipers Stopped - in a SNOW Storm! pagosajoe Fleetwood Products Owner's Forum 4 05-23-2015 10:08 AM
2015 Thor Vegas Wipers hbjcw Class A Motorhome Discussions 3 04-20-2015 07:51 PM
Wipers will not turn off azscooter Winnebago Industries Owner's Forum 4 10-18-2014 12:59 PM
Wipers not returning back to center 2000 Southwind JWLSC Fleetwood Products Owner's Forum 3 01-09-2014 01:18 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:35 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.