Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > New Member Check-In
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-24-2013, 08:31 AM   #1
Junior Member
 
dellajacono's Avatar
 
Join Date: Dec 2013
Posts: 6
Battery and Generator Start-up

I am a new RV'er and picked up my Class C yesterday to run the generator. Well, I pressed the bottom to start the generator but did not turn the battery turn-of switch to on so I'm assuming I drained the battery. Well, I took it to a Cummings shop and they told me to drive the RV for awhile and it should recharge the house batteries. It didn't. So I drove the RV back to my storage area since it was gong to close in an hour.

With that said does anyone know what could have happened? I have no battery power to run the lights or even the radio but the vehicle starts up fine?

Thank you for any insights out there.
__________________

__________________
dellajacono is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-24-2013, 08:54 AM   #2
Senior Member/RVM #90
 
MSHappyCampers's Avatar


 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 26,328
Welcome to IRV2! It's great to have you join the gang!

Sorry I can't help with your question. Enjoy the forum!



MERRY CHRISTMAS & HAPPY NEW YEAR!
__________________

__________________
Joe & Annette

2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is offline   Reply With Quote
Old 12-24-2013, 09:18 AM   #3
Registered User
 
mel s's Avatar
 
Join Date: Mar 2010
Posts: 8,777
Quote:
Originally Posted by dellajacono View Post
I am a new RV'er and picked up my Class C yesterday to run the generator. Well, I pressed the bottom to start the generator but did not turn the battery turn-of switch to on so I'm assuming I drained the battery. Well, I took it to a Cummings shop and they told me to drive the RV for awhile and it should recharge the house batteries. It didn't. So I drove the RV back to my storage area since it was gong to close in an hour.

With that said does anyone know what could have happened? I have no battery power to run the lights or even the radio but the vehicle starts up fine?

Thank you for any insights out there.
dellajcono

Did the generator start?
On some coaches the genset starts with 12VDC from the house batteries, others from the chassis battery.

Do you mean you have no headlights, or house lights?

If the engine starts and the headlights work your chassis battery is apparently okay.

I don't understand what you mean by "battery turn-of switch".
However, it may have to be ON for 12V items in the coach to work?
OR the batteries may not charge with the alternator if the switch is OFF?

A short drive will not charge very low or dead batteries very much.
It could take many miles/hours of driving to fully charge them.

Depleted house batteries may be your only problem.
Put a charger on your house batteries, charge them fully, and try everything again.

Good luck.

Mel
'96 Safari
__________________
mel s is offline   Reply With Quote
Old 12-24-2013, 09:20 AM   #4
Senior Member
 
Country Coach Owners Club
Retired Fire Service RVer's
Join Date: Feb 2013
Location: Ocala, Florida
Posts: 6,295
Welcome and glad to meet you!
__________________
FMCA #F431170, GS #822128658, Escapees SKP #112655
2012 Airstream Mercedes Interstate Class B
[SIGPIC][/SIGPIC]
Medico is offline   Reply With Quote
Old 12-24-2013, 09:47 AM   #5
Junior Member
 
dellajacono's Avatar
 
Join Date: Dec 2013
Posts: 6
Thank you for the quick reply. The generator did not start nor do I have house lights when turned on and the radio upfront doesn't work. The chassis battery is fine I think. Will put a charger on and we'll see what happens.
__________________
dellajacono is offline   Reply With Quote
Old 12-24-2013, 11:50 AM   #6
Community Administrator
 
JohnRR's Avatar


 
Fleetwood Owners Club
Workhorse Chassis Owner
Join Date: Sep 2010
Location: Marquette, Michigan "Da UP"
Posts: 16,940

Good luck with your search.
__________________
John & Cathy R.
06 Pace Arrow 38L W24
08 14 Lincoln MKX AWD
See My RV Upgrades
JohnRR is online now   Reply With Quote
Old 12-24-2013, 12:06 PM   #7
Senior Member
 
monkey's Avatar
 
Join Date: Sep 2011
Location: Arkansas
Posts: 2,250
For what little I know, (I'm learning) I would say the "coach/house" battery is dead or disconnected by way of the "battery disconnect switch" ... If it is disconnected by the switch, it won't charge. Take a simple volt/ohm meter and check both battery voltages. You might tell us what brand/year of class C you have so we can further help. And Welcome to IRV2 !!! Monkey
__________________
Monkey, pilot of a Great Dane hauler,
2015 Silverado 2500 Duramax/Alison 4x4 CrewCab 2016 Cougar 28SGS
1ST CAV
monkey is offline   Reply With Quote
Old 12-24-2013, 02:07 PM   #8
Junior Member
 
dellajacono's Avatar
 
Join Date: Dec 2013
Posts: 6
I have a 2014 Forest River Forrester. When I initially started the generator I forgot to turn on the battery disconnect switch.
__________________

__________________
dellajacono is offline   Reply With Quote
Reply

Tags
battery, generator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:13 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.