Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > New Member Check-In
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-09-2010, 01:19 PM   #1
Junior Member
 
Join Date: Oct 2010
Posts: 1
Red face Hello-

Hello everyone- I'm new to this forum. I joined because of a problem with my LCI levelers on my Georgetown. Sometimes, when I start the coach all of the LED's flash and I can't access the levelers. Othertimes, everything is fine. Any ideas as to what I'm doing wrong? I always check the parking brake first and the coach is running.
__________________

__________________
wildcatmlm is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-09-2010, 02:45 PM   #2
Senior Member
 
azloafer's Avatar
 
Winnebago Owners Club
Join Date: Oct 2009
Posts: 1,170
Quote:
Originally Posted by wildcatmlm View Post
Hello everyone- I'm new to this forum. I joined because of a problem with my LCI levelers on my Georgetown. Sometimes, when I start the coach all of the LED's flash and I can't access the levelers. Other times, everything is fine. Any ideas as to what I'm doing wrong? I always check the parking brake first and the coach is running.
What happens if you do not start the coach, but just turn the key to the accessory position? Just guessing...someone will have the answer soon. Happy trails, Joe
__________________
2008 Itasca Latitude 39W. Cummins ISB 6.7 Turbo 340HP. Allison 6 Speed. Freightliner XCS. Michelin XRV 255/80R 22.5 LRG. SuperSteer MCU. Safe-T-Plus.
azloafer is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:53 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.