Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > New Member Check-In
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 02-29-2016, 06:15 AM   #1
Junior Member
Join Date: Feb 2016
Posts: 2
Left turn signal makes all lights in rear flash

Have checked all bulbs front blinkers are good right rear is good left rear all lights flash in rear both sides

2001 Monaco diplomat

Bigmo is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-29-2016, 06:29 AM   #2
Senior Member
stuhly's Avatar
Fleetwood Owners Club
Join Date: Jan 2010
Posts: 1,202
Check the ground on that light.

stuhly is offline   Reply With Quote
Old 02-29-2016, 06:33 AM   #3
Senior Member
Join Date: Jul 2014
Posts: 5,497
Bad ground, bad bulb or wrong bulb in left rear light.

If you can look at the filament in the bulb, see if both are lighting. That's a sign of bad ground to that socket. It is seeking ground thru the oposite tail light filament, then to ground.
twinboat is offline   Reply With Quote
Old 02-29-2016, 06:58 AM   #4
Senior Member
ronjhall's Avatar

Join Date: Oct 2011
Posts: 914
Make sure bulb is correct one and is installed properly in socket.
2004 Endura 6340D
2012 Chevy Captiva toad
ronjhall is offline   Reply With Quote
Old 02-29-2016, 07:55 AM   #5
Senior Member/RVM #90
MSHappyCampers's Avatar

Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 19,284
Welcome to IRV2! We're sure glad you joined us!

I too would suspect a bad ground! Keep her between the ditches!

Good luck, happy trails, and God bless!
Joe & Annette

2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is offline   Reply With Quote
Old 02-29-2016, 08:28 AM   #6
Moderator Emeritus
Bruce C's Avatar
Nor'easters Club
Fleetwood Owners Club
Workhorse Chassis Owner
Join Date: Dec 2011
Location: NH
Posts: 5,100
Bruce & Nancy
FMCA F280542
2004 Bounder 35E
US Navy Vet.
Bruce C is offline   Reply With Quote
Old 02-29-2016, 10:24 AM   #7
Senior Member
TonyDi's Avatar

Join Date: Feb 2011
Location: Point Pleasant Beach, NJ
Posts: 6,238

Glad your here with us.

I agree check the ground.
Tony & Ruth........... FMCA#F416727
Newmar Dutch Star 4320, Spartan MM Chassis, Cat C9, Jeep Grand Cherokee,with Hemi, hooked up with a Blue Ox Aventa LX, and Brake Buddy.
TonyDi is offline   Reply With Quote
Old 02-29-2016, 09:13 PM   #8
Junior Member
Join Date: Feb 2016
Posts: 2
Found it

Thank you all who answered
Problem was at the trailer plug
Bigmo is offline   Reply With Quote
Old 03-03-2016, 04:20 PM   #9
Senior Member
denlock's Avatar
Newmar Owners Club
Spartan Chassis
Join Date: Feb 2005
Location: Sterling Heights, MI
Posts: 2,724

Tricia & Dennis Lockhart
2010 Ventana 4333
Spartan MM w/Cummins 360 ISC
denlock is offline   Reply With Quote

light, lights

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Left signal causes all lights to flash trvlsupreme Class A Motorhome Discussions 19 06-21-2015 08:59 AM
L Turn signal and middle light won't flash - help RV Play-Timers Travel Supreme Owner's Forum 1 12-11-2011 02:26 PM
no left turn signal on toad bionicman Tiffin Motorhomes Owners Forum 4 09-09-2010 08:47 AM
No Power to Left Turn Signal at Hitch tbussche Ford Motorhome Chassis Forum 7 05-19-2009 02:33 PM
Left Brake Light/Turn Signal Not Working On Towed Jeanne M. Winnebago Industries Owner's Forum 4 02-11-2008 07:43 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:44 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.