Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > New Member Check-In
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 03-29-2011, 10:59 AM   #1
Junior Member
Join Date: Mar 2011
Posts: 2
New member from Occidental CA

I have a 6 gal Suburban water heater in my Lance camper with a switch at the control panel. When turned on the burner fires and runs for about 5 seconds then shuts off. This process occurs three times but the burner won't stay on. Any ideas?

Randy Erwin is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-29-2011, 11:23 AM   #2
Senior Member
Join Date: Feb 2011
Location: Cartersville, GA
Posts: 133
Bad safety switch. Almost all gas heaters have a heat sensor so gas doesn't run with no flame. If it's faulty, it's tell the gas 'no flame' so it shuts off. I think, so therefore I am.

But the true travelers are they who leave for leaving’s sake
Saying continuously, without knowing why: ‘Let us go on’.
Paraphrased from Baudelaire’s ‘The Journey’

Joe and Penny
Mischief and Spanky (Shih Tzus)
2013 Crossroads Z-1 29' Travel Trailer
thelastplace is offline   Reply With Quote
Old 03-30-2011, 07:08 AM   #3
Community Moderator
Petro's Avatar

Winnebago Owners Club
Freightliner Owners Club
Join Date: Dec 2003
Location: Weyauwega, WI US
Posts: 5,212

Welcome to iRV2. We are glad you found us. Sorry I can't help you with your problem. If you would repost your question in our RV Systems & Appliances Forum you will likely receive several answers. Click Here

Don & Bev Morgan Weyauwega WI, 05 Itasca Horizon 40KD, 400 HP Cummins, Delorme GPS LT 40, Toad 07 Saturn Vue AWD, Air Force One, TST 510 TPMS, Mayor of Weyauwega 2007 - 2013, Waupaca Co Board Supervisor 2010 - 2014
Petro is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:14 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.