Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > New Member Check-In
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 09-23-2011, 08:26 PM   #1
Junior Member
Join Date: Sep 2011
Location: MA
Posts: 1
New to iRV2 and Fleetwood Revolution question

I am new to the forum, so first hello!

We have a 2004 Fleetwood Revolution with a strange issue happening,
wondering if anyone can help.

When idling for 10 minutes or more (either in traffic or anytime at idle for
more than a few minutes, the dash alarm buzzer goes on, then the lights for oil, water and battery all come on, at the same time most all the gauges go out. We lose the speedometer, tach, odometer, the only
thing left working are the air gauges. The coach runs along fine, but
with no gauges. After getting back up to speed of 60+ mph they go
off once cruising along. We stopped to have it checked (truck diesel
mechanic), they don't know what it is.

Has anyone heard of anything like this?
Thanks for any help you could give.

Lynne MA is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-23-2011, 08:54 PM   #2
Senior Member
SkiPat's Avatar
Appalachian Campers
Coastal Campers
Carolina Campers
Join Date: Aug 2011
Location: North Carolina
Posts: 219
Welcome to the forum Lynne. Can't answer your question but I'm sure someone will be able to help you out. There are lots of very knowlegable people here.


Skip & Pat
Prince, our Siberian Husky and Tori, our Yorkie
SkiPat is offline   Reply With Quote
Old 09-24-2011, 01:41 AM   #3
Senior Member
HeapBigEngin's Avatar
Join Date: Apr 2010
Posts: 635
Since the problem seems to be on the chassis battery side rather than on the house side, I would first take a look at battery connections, battery conditions, grounds, etc. here. How old are the batteries (should be 2) in your Revolution? Almost sounds like the coach can be started because of some residual charge left in the batteries....but then the batteries are petering out or are unable to get a charge or hold a charge from the alternator, causing a voltage issue downstream at the gauges and other electrical issues. I believe that on most newer fuel injected/computerized vehicles (which yours is), the alternator should provide adequate power to both charge the batteries as necessary AND to operate the engine. Even if the batteries were to be disconnected after start up (and I do NOT recommend that), the motor should continue to run via the alternator. On fuel injected/computerized systems, weak alternators that cannot both power the motor and charge the batteries will cause serious driveability issues over time. That does not sound like what you have here. Batteries and connections is where I would look first.

On my fuel injected/computerized street rod, after I start the vehicle, I can "throw" the battery kill switch to "off"....and the vehicle keeps on running just fine. However, none of the gauges, accessories or lights will work. I learned this after chasing an electrical gremlin in the computer and alternator for several months....and I do not want to "learn" this over again. Kinda' sounds like what you have going on....

Hopefully, some others will chime in with their thoughts and suggestions. Please let us know what you find out here.....thanks!
2003 Fleetwood Revolution DP
HeapBigEngin is offline   Reply With Quote
Old 09-24-2011, 05:01 AM   #4
Senior Member
Join Date: Jan 2011
Location: Fort walton Beach Fl
Posts: 625
I would looks at the Batterys 1st. I have seen lots of crazy stuff happen due to a bad battery and yet the unit will still start.
Lault is offline   Reply With Quote
Old 09-24-2011, 06:55 AM   #5
Senior Member
Elkhartjim's Avatar

Texas Boomers Club
Fleetwood Owners Club
Freightliner Owners Club
Join Date: Jul 2008
Location: Don't mess with Texas
Posts: 3,115
If you're on a Freightliner chassis it could be a problem with the LBCU...Light Bar Control Unit.

Give Freightliner Help Desk a call, if you're FL, at 1-800-FTL-HELP. You will need the last 6 digits of your VIN.

If you're a Spartan Chassis I would give their help desk a call. The folks answering these phones are technically savvy.
Jim with Judy
08 38' Bounder DP
Toads: 08 Jeep Wrangler Sport; 11 Chevy Malibu
Elkhartjim is offline   Reply With Quote
Old 09-24-2011, 08:35 AM   #6
Senior Member/RVM #90
MSHappyCampers's Avatar

Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 19,302
Hi Lynne! Welcome to IRV2! You'll probably get more answers to your question if you post it over in the MH section. Good luck & God bless!
Joe & Annette

2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is offline   Reply With Quote
Old 09-24-2011, 08:58 AM   #7
Senior Member
Purplefans & Harvey's Avatar
Nor'easters Club
Fleetwood Owners Club
Mid Atlantic Campers
Workhorse Chassis Owner
Join Date: Oct 2008
Location: Medway, MA
Posts: 395
Hi Lynn - welcome to the forum! It's a great place for information, and feeling connected to the Rving community! How do you drive that MH on those twisty tiny roads in Harvard?

Landcruisers for life
2 adults, 2 kids (tweens) and 2 dogs
2004 Fltwd Southwind 32V from 2000 Tioga 26F
Purplefans & Harvey is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fleetwood forum karma hondo122 Fleetwood Products Owner's Forum 62 09-14-2014 09:52 AM
Is newmar becoming another fleetwood? Nancy Fisher Newmar Owner's Forum 21 06-10-2012 07:20 PM
Question about Fleetwood Slides jrshall Fleetwood Products Owner's Forum 24 05-22-2010 05:59 AM
Announcement to All Fleetwood Owners RVrs R US Fleetwood Products Owner's Forum 28 01-26-2005 10:36 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:33 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.