Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > New Member Check-In
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-24-2007, 07:48 AM   #1
Junior Member
 
Join Date: Nov 2005
Location: Cape Cod Massachusetts
Posts: 5
I could use your input.
I have a new 2007 33 Voyage with a 2007 workhorse. Love this oombo. w-20

1-- right from the get go the dash air was not cooling well if at all. Crossroads RV under workhorse repalaced the compresser. it was better but air never condences, I have never seen any water drips comming from the tube, under the condenser. tube is not blocked.

On the way home from this repair. The Trany light commes on and locks up in 4th gear. Try and start up at a trafic light in forth to get off the road is not real easy. Called workhourse and they say that air and trany are not connected. Coach sat for 5 min turned off while I called with my cell phone. Decided to see it trany light was still on. Light off and trany seemed just fine. Drove it back to Crossroads. They didn't see any codes and tested the air and said it was up to 300lbs pressure and evecuted the air system and eveything should by fine.
2.-- Went on a trip to SC form Cape Cod Mass. Drove pretty much straight through. Notice it was hot out. 97 degrees and dash air was not even close to cooling us off. Next thing I notice is the coach shifting and I'm in fourth gear again and trany light is on. Let coach sit for five min everything seems fine. Take it to workhorse center and they get no codes again and find the air needs more coolent. they recommend I take it ir to allison. Workhourse says no. They should call there tec and there has been some other 2007 with the the same problem. I decided to wait till I was back home before looking further for the problem.

3.--Im back at Crossroads now and they have my coach and today there is a workhouse rep comming to see my coach.

4. Should the air, condence mositure in humid weather? yes or no. No one seems concerned execept me.
5. My radiator looks like it has a tran cooler in front of the normal radiator?? (lower bottom)
One of the posts had a picture of 2007 radiator and mine looks different??
6. Tec in SC wondered where the auillary fans where? Thought that heat buildup might be the problem.
Drove all the way home and no problem. cant duplicate the tran light come on. Not hot enough in Mass. now that it is fall.
8. Are there any other 2007 w-20 having simmiler issues?

Work horse wanted to know if i was in the mountains pulling a car etc. None of these are the case, I on 95 south most of the trip. don't tow, and didn't go up any mountains.
I fact it was after comming off the highway and in traffic. Water temp just perfect. no indication of any overheating, smell etc.

Any help would be appreciated. 12000 miles now and love this coach. Would love to solve this issue.

John
__________________

__________________
roadtrec is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-24-2007, 07:48 AM   #2
Junior Member
 
Join Date: Nov 2005
Location: Cape Cod Massachusetts
Posts: 5
I could use your input.
I have a new 2007 33 Voyage with a 2007 workhorse. Love this oombo. w-20

1-- right from the get go the dash air was not cooling well if at all. Crossroads RV under workhorse repalaced the compresser. it was better but air never condences, I have never seen any water drips comming from the tube, under the condenser. tube is not blocked.

On the way home from this repair. The Trany light commes on and locks up in 4th gear. Try and start up at a trafic light in forth to get off the road is not real easy. Called workhourse and they say that air and trany are not connected. Coach sat for 5 min turned off while I called with my cell phone. Decided to see it trany light was still on. Light off and trany seemed just fine. Drove it back to Crossroads. They didn't see any codes and tested the air and said it was up to 300lbs pressure and evecuted the air system and eveything should by fine.
2.-- Went on a trip to SC form Cape Cod Mass. Drove pretty much straight through. Notice it was hot out. 97 degrees and dash air was not even close to cooling us off. Next thing I notice is the coach shifting and I'm in fourth gear again and trany light is on. Let coach sit for five min everything seems fine. Take it to workhorse center and they get no codes again and find the air needs more coolent. they recommend I take it ir to allison. Workhourse says no. They should call there tec and there has been some other 2007 with the the same problem. I decided to wait till I was back home before looking further for the problem.

3.--Im back at Crossroads now and they have my coach and today there is a workhouse rep comming to see my coach.

4. Should the air, condence mositure in humid weather? yes or no. No one seems concerned execept me.
5. My radiator looks like it has a tran cooler in front of the normal radiator?? (lower bottom)
One of the posts had a picture of 2007 radiator and mine looks different??
6. Tec in SC wondered where the auillary fans where? Thought that heat buildup might be the problem.
Drove all the way home and no problem. cant duplicate the tran light come on. Not hot enough in Mass. now that it is fall.
8. Are there any other 2007 w-20 having simmiler issues?

Work horse wanted to know if i was in the mountains pulling a car etc. None of these are the case, I on 95 south most of the trip. don't tow, and didn't go up any mountains.
I fact it was after comming off the highway and in traffic. Water temp just perfect. no indication of any overheating, smell etc.

Any help would be appreciated. 12000 miles now and love this coach. Would love to solve this issue.

John
__________________

__________________
roadtrec is offline   Reply With Quote
Old 10-24-2007, 09:58 AM   #3
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 26,788
Welcome roadtrec to irv2.
Alot of WH owners have had Evans AC problems some have placed a ball valve in heater line to cut off the hot water into the heater coil that defeats the AC portion of Evans unit. Link to ball valve
Your coach is still under warranty and dealer should replace the Evans control valve.
TRANNY may have to be reprogramed by Allison don't think dealer can handle problem.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans, now in good hands
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is online now   Reply With Quote
Old 10-24-2007, 02:50 PM   #4
Senior Member
 
Edmund A Skibinski's Avatar
 
Join Date: Feb 2000
Location: Erie, PA
Posts: 1,070
roadtrec, Welcome to the IRV2 website, hope the anwser you received solves your problem. Ed.S
__________________
2005 Newmar Mountain Aire W-24 , 2006 Jeep Commander Limited towed vehicle Newmar Kountry Klub 7284L, Pennsylvania State Directors
Edmund A Skibinski is offline   Reply With Quote
Old 10-24-2007, 04:24 PM   #5
Senior Member
 
Oemtech's Avatar
 
Join Date: Feb 2003
Location: Jarrell, TX 76537
Posts: 4,243
Send a message via AIM to Oemtech
This is a way out in left field shot....

But, when we have installed UltraPower we have found a couple coaches with miss matched PCM/TCM combos.
__________________
Dale
AKA - Oemy
Oemtech is offline   Reply With Quote
Old 10-24-2007, 04:27 PM   #6
Senior Member
 
max49's Avatar
 
Damon Owners Club
Workhorse Chassis Owner
Join Date: May 2005
Location: Parker, CO
Posts: 3,102
Sorry to hear about having problems with a brand new coach. My AC works acceptably, I guess. It wasn't acceptable when it was new, but after taking it to 2 different svc cnts, and they said it's a good as it gets, I learned to accept it. It absolutely does not cool if your idling or in a traffic jam but gets luke cool when driving. I also put a manual ball valve in the hose that goes to the heater core but I'm not sure it helped.
I don't have an Allison Transmission, but most everybody on this site says they are "bulletproof", for what that's worth. I guess you can shoot it and it won't get any worse, but it inexcusable, to have these problems with a brand new vehicle. Even tho it should be under warranty, its still a big hassle. So if you were towing and/or in the mountains, then it would be your fault???
__________________
Max
2018 Gulf Stream Conquest 6238 on Ford E-350 Super Duty
Parker, Colorado
max49 is offline   Reply With Quote
Old 10-26-2007, 01:21 AM   #7
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
roadtrec, welcome to iRV2.com. Wea re glad to have you join us here. Congratulations on your new Voyage. Hopefully WOrkhorse will get the problem resolved quicky for you. Let us know what they find and do to correct the issue. I am sure you will recieve a lot of replys and readers following this issue. GOod luck and enjoy the website.
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 10-28-2007, 06:50 PM   #8
Senior Member
 
Skip- Kerrville, TX's Avatar
 
Join Date: Aug 2003
Location: Ingram, TX
Posts: 310
hi roadtrec, and welcome to irV2. It's a real dissappointment to have these kinds of problems with a new rig, but I'm sure that in working with Workhorse and your dealer you will get them straightened out.
__________________
If interested, come visit us in the iRV2 Chatters chat room. We're there just about every evening from about 8:30pm eastern until about 10:00pm. It's a great bunch of folks!

Skip- Kerrville, TX is offline   Reply With Quote
Old 10-29-2007, 05:24 AM   #9
Junior Member
 
Join Date: Nov 2005
Location: Cape Cod Massachusetts
Posts: 5
Up date on Trany

Workhourse will be installing two front fans that they discontinued in 2007. They say that there is a memo out there with other 2007 that are having the same poblem. the thinking is to hot in engine compartmet that sets off the sensor on the trany.

Air conditioning Workhorse will be installing a Provison kit. Don't know what that is but they said it would increase the cooling signifcantly.

Workhorse has step up to the plate for sure. will let you know wether the fixes work. Will be complete next week.

John
__________________

__________________
roadtrec is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Air Conditioning JMJCSIM MH-General Discussions & Problems 11 03-27-2008 05:00 PM
loss of air conditioning and fresh air through vents cwg Newmar Owner's Forum 2 03-31-2007 07:45 PM
Air Conditioning problems Donald Workhorse and Chevrolet Chassis Motorhome Forum 2 09-27-2006 04:53 PM
Air Conditioning iron mike Alpine Coach Owner's Forum 3 06-29-2005 07:10 AM
Trany light and air conditioning??? Workhorse and Chevrolet Chassis Motorhome Forum 8 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:37 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.