Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > New Member Check-In
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 03-17-2014, 10:54 AM   #1
Junior Member
Join Date: Mar 2014
Posts: 6
wiring harness

Hi all,

Could any body please help, I own a holiday rambler arista 2008 model year,
up until last week my screen wash pump did work and now its not

I have done several tests and i have no power to the wires in which connects to the pump
when i twist the stalk the wiper work but no power to the screen wash pump, i have checked all fuses and are all good.

would it be the indicator stalk now faulty ???

Also what i would like is a wire diagram for my rv is there any body out there who could email me this or could tell me on how i could download this wiring diagram ?
thank you to all that can help me.
Jason Kent from England united kingdom

jkent19 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-17-2014, 12:42 PM   #2
Community Administrator
JohnRR's Avatar

Fleetwood Owners Club
Workhorse Chassis Owner
Join Date: Sep 2010
Location: Marquette, Michigan "Da UP"
Posts: 14,882

I can't offer you any help but good luck with your search.

John & Cathy R.
06 Pace Arrow 38L W24
08 Lincoln MKX AWD
See My RV Upgrades
JohnRR is offline   Reply With Quote
Old 03-18-2014, 03:28 AM   #3
Senior Member
Country Coach Owners Club
Retired Fire Service RVer's
Join Date: Feb 2013
Location: Ocala, Florida
Posts: 6,295
Welcome and glad to meet you!

Posting in a more appropriate category for your problem will most likely elicit more answers. Many of the mechanical experts do not visit the New Member Forum.
FMCA #F431170, GS #822128658, Escapees SKP #112655
2012 Airstream Mercedes Interstate Class B
Medico is offline   Reply With Quote
Old 03-18-2014, 07:57 AM   #4
Senior Member/RVM #90
MSHappyCampers's Avatar

Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 19,302
Hi Jason! Welcome to IRV2! It's great to have you join the gang!

Sorry I can't help with your problem! Enjoy the forum!

Good luck, happy trails, and God bless!
Joe & Annette

2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is offline   Reply With Quote
Old 05-06-2014, 11:25 AM   #5
Junior Member
Join Date: Apr 2014
Posts: 11
It is probably a faulty wiper control. That's the arm on the sterring wheel that controls the wipers,windsheild washer,cruise control etc. I also have an '08 Arista and my wipers quit. This was the problem. Just to be sure,locate the pump and jump it with a battery and see if it works. If it does ,than for sure it is the control. You might want to take it to a mechanic if this sounds intimidating. The controls are not cheap. I got an after market control for $250 CD. Mine is GM workhorse chassis. If yours is the ford then you may have some other problem. Hope this helps.
Scott hadley is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mopar Wiring harness Gladie Toads and Motorhome Related Towing 86 08-24-2016 10:08 AM
2013 CRV Toad Wiring Harness TheJeep Toads and Motorhome Related Towing 5 04-05-2014 07:44 PM
Winnebego Tow Wiring Harness GaDawgFan Winnebago Industries Owner's Forum 15 03-22-2014 01:52 PM
What wiring Harness for 2013 F150 Ecoboost hardy1000 Toads and Motorhome Related Towing 3 12-13-2013 03:20 PM
Need help in locating the wiring harness for a brake controlller for a 2005 vectra Catcoach Winnebago Industries Owner's Forum 11 11-24-2013 05:32 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:26 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.