Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > Just Conversation
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 02-03-2015, 10:29 AM   #1
Junior Member
 
Join Date: Feb 2015
Posts: 3
Troubleshooting A Roof vent/fan

Hi All,

New to RVing and we have a 26' Born Free Class C. She is in real nice shape. The vent fan above the main salon, a Fan-Tastic vent/fan with reverse and a water sensor, just stop moving. The motors whir and spin and it sounds like it is working, but nothing moves.

Before I take it apart, which will be a hassle, I wanted to see if any advice is out there on this 14 inch fan.

Thanks...Tom
__________________

__________________
Tom Happe is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-03-2015, 10:35 AM   #2
Senior Member
 
onlakegaston's Avatar
 
Workhorse Chassis Owner
Join Date: Jul 2013
Location: Somewhere
Posts: 301
First of all Welcome !
Have you checked the allen set screw to see if it is tight?
__________________

__________________
Jim, Lisa and Reno
2003 Coachmen Aurora Gold 3510DS Ultra Power Koni FSD Scan Gauge II
Full Time in Mission TX for winter.
onlakegaston is offline   Reply With Quote
Old 02-03-2015, 11:16 AM   #3
Senior Member
 
Arch Hoagland's Avatar
 
Monaco Owners Club
Workhorse Chassis Owner
Join Date: Aug 2002
Location: Clovis, CA, USA
Posts: 5,887
I'd suggest calling Fan-Tastic and explain the problem.

Their customer service gets rave reviews on here.

http://www.fantasticvent.com/
__________________
2004 Monaco La Palma 36DBD, W22, 8.1, 7.1 MPG
2000 LEXUS RX300 FWD 22MPG 4020 LBS
Arch Hoagland is offline   Reply With Quote
Old 02-03-2015, 06:37 PM   #4
Senior Member
 
98FPA's Avatar
 
Fleetwood Owners Club
Join Date: Nov 2013
Location: Sunrise In Central Nebraska
Posts: 579
My suggestion is the same as onlakegaston's in checking the set screw on the fan. If the motor is turning the blade isn't that very well could be the problem. On my Fantastic fan, I had a heck of time breaking the set screw loose to remove the fan to clean. Finally it did break loose, I had contacted Fantastic Fan about it the removal, etc. and I too received a very prompt reply. Went to camper show this past weekend and a lot of the campers had this fan unit in them. Great fan for sure.
__________________
Ken in Nebraska
98 Fleetwood Pace Arrow, 35U
97 Ford F53 chassis
98FPA is offline   Reply With Quote
Old 02-04-2015, 04:14 AM   #5
Junior Member
 
Join Date: Feb 2015
Posts: 3
Thanks, everyone. It is the dome opening mechanism/track that seems to be off. The dome motor works fine. The fan doesn't go on due to the track mechanism being unable to open or close the dome. The dome opens freely with a push up with, say, a long stick but it is off track. The track mechanism seems out of whack. I did try calling them but the long wait times have frustrated me. I will try again today.

Tom Happe
'99 Born Free 26'
E450 Ford
__________________
Tom Happe is offline   Reply With Quote
Old 02-04-2015, 08:41 AM   #6
Senior Member
 
98FPA's Avatar
 
Fleetwood Owners Club
Join Date: Nov 2013
Location: Sunrise In Central Nebraska
Posts: 579
Tom, may be just as easy to take it apart, etc. and take a look at it. Usually those tracks are too complicated but I can't remember for sure what it looked like when I had mine apart. My contact with them was through an email.
__________________
Ken in Nebraska
98 Fleetwood Pace Arrow, 35U
97 Ford F53 chassis
98FPA is offline   Reply With Quote
Old 02-04-2015, 03:26 PM   #7
Senior Member
 
monkey's Avatar
 
Join Date: Sep 2011
Location: Arkansas
Posts: 2,250
Not sure if its the same as yours,,, but one of our "domes" came loose from the mechanism.. The small plastic wheel that connects the arm to the "dome/cover" had broken.. Took me about 10 minutes to install a small bolt, double nutted, and a couple washers. Works great now.... Monkey
__________________
Monkey, pilot of a Great Dane hauler,
2015 Silverado 2500 Duramax/Alison 4x4 CrewCab 2016 Cougar 28SGS
1ST CAV
monkey is offline   Reply With Quote
Old 02-06-2015, 09:15 AM   #8
Junior Member
 
Join Date: Feb 2015
Posts: 3
Thanks you members. Once I got in touch with Technical Support the determined that my dome arm had somehow disconnected at the motor end. For the cost of shipping they are replacing the motor arm and adding a new dome. FAN-TASTIC FAN is truly living up to their guarantee...this is a 1999 version and they are replacing the parts at their cost...SIMPLY AMAZING!
__________________

__________________
Tom Happe is offline   Reply With Quote
Reply

Tags
fan, roof, vent



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New rubber roof, just replaced, same issues 1010 Outdoors RV Owner's Forum 8 11-20-2014 02:05 PM
Excel to Offer New "Lifetime" Roof System ExcelRVGuy Excel Owner's Forum 22 11-19-2014 10:15 PM
Roll-on bed-liner roof project 99 Starcraft 5th Wheel Discussion 14 10-03-2014 04:29 PM
Flat Roof and Email to Winnebago n5pht Winnebago Industries Owner's Forum 19 06-09-2014 12:08 PM
another roof problem pattcook Winnebago Industries Owner's Forum 9 04-22-2014 07:54 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:47 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.