Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > Vintage RV's
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-08-2012, 08:19 PM   #1
Junior Member
 
Vintage RV Owners Club
Fleetwood Owners Club
Join Date: Sep 2012
Location: Munday,Tx
Posts: 6
1988 fleetwood limited converter problems

I just bought this motorhome Iam brand new to this. I have the power cord pluged in to shore power getting 240 AC volts to my power converter but I have no power in motorhome. When I turn breaker on at converter it hums loudly for 1-4 sec then cuts off by tripping the breaker any ideas on what to do. Thanks for helping
__________________

__________________
kbibbers is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-08-2012, 08:22 PM   #2
Senior Member
 
DonDee's Avatar
 
Join Date: May 2012
Location: Spring Valley AZ
Posts: 1,204
240v is the problem
__________________

__________________
Don, Mary and Spooky
'00 Bluebird Skoolie Conversion
Geo Tracker/Dodge Neon/Aprilia Scooter towed
DonDee is offline   Reply With Quote
Old 09-08-2012, 09:38 PM   #3
Senior Member
 
Join Date: Jul 2011
Posts: 221
Sounds like you plugged into a 30amp receptacle for something like a home clothes dryer. If the circuits in your rig hadn't tripped you could have fried many things .... you'll need to look for any damage regardless. And if you haven't already done so, unplug your rig from that receptacle now!

Sounds like right now you don't have access to a 30amp receptacle wired for an RV. So go buy an adapter that will let you plug your RV's power cord into a standard residential power outlet. The adapter costs just a few bucks, and is available at any camping or outdoor supply store. Might also be available in Walmart.

If you're new to RVs you might want to invest in a book for new RVers. Read your RV's manuals and papers if you have them, too. This forum has lots of info as well.

Congratulations on your Fleetwood! :-)
__________________
[B]BichonLover is a 100% California gal, driving a vintage Fleetwood in SoCal.
BichonLover is offline   Reply With Quote
Old 09-09-2012, 06:27 AM   #4
Senior Member
 
nightriderrv's Avatar
 
Fleetwood Owners Club
Join Date: May 2012
Location: NC
Posts: 1,682
Sounds like another dryer plug smoke test

No 240V on a 3 prong plug period !!!! 120 @ 30 amps only
__________________
Mark Anderson - Nebo NC - western NC - RV Restoration tech - 9 Doggies - Outdoors person
1990 33ft Wilderness Cimarron 33X
nightriderrv is offline   Reply With Quote
Old 09-09-2012, 12:24 PM   #5
Junior Member
 
Vintage RV Owners Club
Fleetwood Owners Club
Join Date: Sep 2012
Location: Munday,Tx
Posts: 6
Thanks for help I have power now. Air condition units work after rewiring rotary selector switch. The refrigerator has 120V at plug but doesn't work. The lights on front control panel work. It also auto selects gas or electric shows electric but never cools. The motorhome had this problem before I bought it. Any ideas Refridge is a dometic brand.
__________________
kbibbers is offline   Reply With Quote
Old 09-09-2012, 03:39 PM   #6
Junior Member
 
Join Date: Sep 2011
Posts: 21
Quote:
Originally Posted by kbibbers View Post
I just bought this motorhome Iam brand new to this. I have the power cord pluged in to shore power getting 240 AC volts to my power converter but I have no power in motorhome. When I turn breaker on at converter it hums loudly for 1-4 sec then cuts off by tripping the breaker any ideas on what to do. Thanks for helping

my e-mail is cmnymark@sympatico.ca
send me yours and i'll send my copy of domtic fridge from my 1988 pace arrow fleetwood.
carl
__________________

__________________
crazycanuck is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:02 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.