Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > Vintage RV's
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-29-2016, 03:03 PM   #1
Member
 
Join Date: Apr 2011
Location: Illinois
Posts: 84
1988 Ford E350 Mallard. Water heater not firing

My atwood G6a-4e water heater on my 1988 class c is not lighting. The ignitor is coming on and has good spark, but no flame.

I have propane as The stove is working fine...

Where do I start?
__________________

__________________
jimzz2001 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-31-2016, 07:28 AM   #2
Senior Member
 
BA-in-Mich's Avatar
 
Join Date: Apr 2011
Posts: 472
Chances are you have a dual solenoid gas valve. If you have an ohm meter pull the wires off of the valve and check for resistance on the coils. I would bet one one or both are open. Resistance should be approximately 80 ohms give or take. I had one of my coils open some years ago. I was able to unwrap a couple of wraps and resolder. Eventually I bought some magnet wire and rewrapped the coil. It's worked fine ever since.
__________________
1990 28' Georgie Boy, 454, 4bbl, Thorley Headers, Recurved Distributor, 8.75 mpg. RVM 76
BA-in-Mich is offline   Reply With Quote
Reply

Tags
heater, ford, water heater, water, heat



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Aspire Aqua-Hot propane burner not firing Kuppajoe Entegra Owner's Forum 12 11-29-2013 07:46 PM
[Oshkosh_Diesel_RV_Chassis] Overland 1990, 1989,1988 Mallard Overland Front Diesel duckie Vintage RV's 3 05-29-2013 08:40 PM
Atwood Furnace Not Firing Cougarkid RV Systems & Appliances 7 01-17-2013 10:16 AM
Furnace not firing cgau RV Systems & Appliances 6 04-28-2010 01:18 PM
fridge not firing up mrsgrubby 5th Wheel Discussion 5 08-23-2005 03:09 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:53 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.