Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > Vintage RV's
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-16-2015, 07:19 AM   #15
Senior Member
 
KSagal's Avatar
 
Join Date: Oct 2014
Location: Wilmington, MA
Posts: 560
My Onan on my recently purchased 88 Southwind would start every time, but only run for about 10 seconds. It would start over and over, but only run for a short time.

I tried some of these fuel solutions, but got some great advice on this forum, which I will pass along now...

Mine has an electric fuel pump, and I found that the power to that pump is not proper. The great suggestion was made to me here, that I might try a different 12 volt source for that pump.

I did. I took a lawnmower battery, and supplied a good solid 12 volts to that pump, and the generator fired right up, and stayed running.

When running, a multi meter showed that the voltage on the original wire to that pump is all over the place.

I ran the inverter for several hours break in, and it runs much better now. I also added sea foam (a fuel cleaner additive) to the the gas tank, but that 80 gallon tank feeds the whole camper.

I have since gone back to the original wire. It starts great, and nearly stalls every 10 or 15 seconds for the first couple minutes. Then it runs well.

I hope this helps on some level. I wish you luck with that carb. If you get that perfect and still have an issue, you may want to look into the power to the pump.

Good luck.
__________________

__________________
Karl I. Sagal KarlSagal@Gmail.com
Well done is better than well said. (Ben Franklin)
1988 Fleetwood Southwind, 34'
KSagal is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-16-2015, 08:12 PM   #16
Junior Member
 
Join Date: May 2015
Posts: 18
Well, I did get a set of long acetylene tip cleaners and the bottom of that hole is hard metal, confirmed by some guy with a special light, and my jabbing it with quite a bit of force.. no go, the bottom is solid. I also probed carefully all along the length of the bore for any sign of an irregularity indicating any sort of sub-passage, blocked or not and I can't feel anything but smooth metal. Took it to two different small engine mechanics and they wouldn't touch it or even comment on whether or not they thought it was an air passage or not. I've got a photo up on smokestak.com where there's people that are nuts for any small engine, special forum for carbs... no feedback on the issue yet from anyone. I agree it should be an air passage but, so far can't actually confirm that.
__________________

__________________
Childeric is offline   Reply With Quote
Old 06-16-2015, 09:03 PM   #17
Junior Member
 
Join Date: May 2015
Posts: 18
Quote:
Originally Posted by KSagal View Post
My Onan on my recently purchased 88 Southwind would start every time, but only run for about 10 seconds. It would start over and over, but only run for a short time.

I tried some of these fuel solutions, but got some great advice on this forum, which I will pass along now...

Good luck.
KSagal, I didn't see your post till just now, thanks. Will give this a try for sure!
__________________
Childeric is offline   Reply With Quote
Old 06-17-2015, 08:59 AM   #18
Senior Member
 
Workhorse Chassis Owner
Join Date: May 2006
Location: Holland, MI
Posts: 470
Manufactures will design a part with several possible holes designed in and use that same part on different models. Some of the holes will be drilled out and some left to confuse people.
__________________
1995 Roadtrek 19 Versatile
Dodge 318
1975 GMC Eleganza II
bsinmich is offline   Reply With Quote
Old 06-17-2015, 08:19 PM   #19
Junior Member
 
Join Date: May 2015
Posts: 18
Quote:
Originally Posted by bsinmich View Post
Manufactures will design a part with several possible holes designed in and use that same part on different models. Some of the holes will be drilled out and some left to confuse people.
Yes, thank you, this was also just confirmed for me on smokstak.com. I think my carb issues at this point are just needing a choke element and the seal on the screw comming up through the bowl is really deteriorated, I definitely need a new one. With any luck, that will be the fix (?).

Smokstak-MMcdonald "That hole and the one symmetrically to the left of it are idle air circuit passages made in all the castings of the marvel schebler VD. The casting has two of them but only one will be completed that is above the idle needle. I can't tell where the idle needle is on your picture so I can't say for sure. For instance if your idle needle is on the right side of center per the picture then that hole does keep going to the idle needle area(but I don't remember off hand if it changes dimensions). If your idle needle is the left of center per the picture then the passage on the left would be completed to the needle area and the right does not lead anywhere. Good luck."
__________________

__________________
Childeric is offline   Reply With Quote
Reply

Tags
onan



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan generator running problems. Heinz Gee Class A Motorhome Discussions 14 09-17-2015 07:45 AM
Generator won't stay running more than a minute toyzforme Newmar Owner's Forum 16 06-13-2015 11:26 AM
Engine turns over but won't stay running elavin Caterpillar Engine Forum 20 08-07-2014 09:10 PM
Running Generator and House AC on road AKJohn Class A Motorhome Discussions 55 05-24-2014 04:17 PM
Onan Generator kathy4360 Class C Motorhome Discussions 10 05-10-2014 12:53 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:39 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.