Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > Vintage RV's
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Thread Tools Search this Thread Display Modes
Old 03-20-2014, 10:23 PM   #1
Join Date: Oct 2012
Posts: 31
Question 97 Beaver problem

I have almost finished bring my 1997 Beaver Montery into the 21st century but I have one last nagging problem. Neither of the TV connections on the outside seem to work.
Behind the front TV (with it removed) there are four standard TV cables comming down from above. One is probably from the Wyngard antenna but I can't get any continuity to them from the TV antenna connect in the wet bay or in the storage bay on the other side of the motorhome. Is there a place where these cables are connected somewhere in between? Why are there 4 TV cables routed up there? There is another cable comming in from the other side of the coach and it doesn't seem to go anywhere either. I have identified the cable comming down from the satilite dish and the one going to the rear TV but I can't figure out where the rest are going, meanwhile the connectors on the outside are useless. Boy am I confused.
If you can shed any light on this problem that would help me I would be really appreciated.
John at RanchoT@msn.com

RanchoT is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-22-2014, 12:26 AM   #2
Registered User
Damon Owners Club
Workhorse Chassis Owner
Join Date: May 2008
Location: N. Palm Springs CA (in winter)
Posts: 2,421
Have you acquired and checked the wiring diagram in the RV Owners Manual?
Doggy Daddy is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Okay ... I SOLVED THE AUTO PARK BRAKE PROBLEM! JerryPeck Workhorse and Chevrolet Chassis Motorhome Forum 119 Today 10:41 AM
Beaver Sub-forum Bill Dean Monaco Owner's Forum 6 03-29-2014 07:42 AM
04 Essex gen starter problem ryankaty Newmar Owner's Forum 1 03-18-2014 08:10 AM
Hadley problem Dave999 Class A Motorhome Discussions 1 01-12-2014 03:57 PM
Fridge Problem Rossi6998 Winnebago Industries Owner's Forum 22 01-10-2014 08:02 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:29 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.