Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > Vintage RV's
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Thread Tools Search this Thread Display Modes
Old 09-25-2013, 08:01 AM   #1
Junior Member
Join Date: Sep 2013
Posts: 9
c'mon forth !

I was told that my 89 HR Imperial has a Turbo 400 tranny. I think I have lost my overdrive because I don't hear or feel it and my RPM is running about 2600 at 55 MPH.
Has anyone had this problem or know what may cause it. Tranny fluid is clean and on the mark. thanx

halsie81 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-25-2013, 08:22 AM   #2
Moderator Emeritus
TXiceman's Avatar

Vintage RV Owners Club
Texas Boomers Club
Oklahoma Boomers Club
Ford Super Duty Owner
Join Date: Aug 2000
Location: Full Time, TX Home Base
Posts: 17,139
Blog Entries: 21
We had an 89 Pace Arrow on the P30 chassis and it did not have an OD transmission. Could be your torque converter is not locking up in 3rd.


Amateur Radio Operator (KE5DFR)|Full-Time! - 2012 6.7L Ford Crew Cab Dually -2013 HitchHiker Champagne 38RLRSB - Travel with one Standard Schnauzer and one small Timneh African Gray Parrot
TXiceman is offline   Reply With Quote
Old 09-25-2013, 04:12 PM   #3
Senior Member
BA-in-Mich's Avatar
Join Date: Apr 2011
Posts: 405
There is no OD on the 400. Mine runs around 3000 at 65mph
1990 28' Georgie Boy, 454, 4bbl, Thorley Headers, Recurved Distributor, 8.75 mpg. RVM 76
BA-in-Mich is offline   Reply With Quote
Old 09-27-2013, 07:00 AM   #4
Senior Member
Mid Atlantic Campers
Join Date: Apr 2010
Location: Charleston, WV
Posts: 224
Yep, no Overdrive in a 400 turbo. I'm pretty sure they never made one with a lockup converter either.
Anyway, your RPM range sounds about right, that's about where mine runs.
Phobos is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:44 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.