Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > Vintage RV's
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Thread Tools Search this Thread Display Modes
Old 09-06-2013, 10:38 PM   #1
Join Date: Aug 2013
Posts: 66
Diesel keeps running but strangely

So I got home tonight and went to shut down my 1990 cat diesel pusher, and it would not stop running, but it was like just barely running and shaking really badly, get this when i turned off the park lights the engine stopped, so I started it turn on the headlights and shut it down and it was fine, restarted it turned on the park lights and guess what engine kept partially running, like the fuel shutwon solenoid is getting some voltage to keep it partially open...........Strange for sure and it does it everytime when the park lights are on, but i have to check again it could be the dashlights, i recently replaced the headlight swith because it was getting hot and i also changed out all the lamps to LED's on the coach but not in the dash lighting. Somehow the park light circuit is back feeding into the ignition circuit but where is the big question.

Any thoughts?

Muledeer2 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-06-2013, 10:48 PM   #2
Join Date: Aug 2013
Posts: 66
update can't duplicate the problem again, everything works fine now, so now what?

Muledeer2 is offline   Reply With Quote
Old 09-06-2013, 11:32 PM   #3
Senior Member
Skip426's Avatar

Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 11,954
About all you can do is check the dash grounds, and wait; for the problem to happen again.
At least you have a way of shutting the engine down , so it could be worse.
Park lights are on when the head lights are on , but you say the problem was only when the light switch was in the park position .Now I'm just as confused as you are.
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:00 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.