Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > Vintage RV's
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-14-2012, 05:35 PM   #1
Member
 
Join Date: Feb 2012
Posts: 34
Ethyl has problems 1986 HR Imperial

Ethyl has problems. After having an electrician run a 10 gauge, 30 amp dedicated circuit out to Ethyl, she got plugged and still no electricity. Nothing comes on. The generator battery is dead (gonna put a trickle charger on that when it gets hooked back up). power inverter won't do anything. Supposedly it's a 110 circuit. Most of the lights run off the battery (also dead, drat that son-in-law of mine). The fridge is 110 and so is the A/C. LP gas which I haven't even messed with yet.
So if anyone has any suggestions, please, please please let me know. I am totally new to RV'ing. Don't even know how to check the tanks and can't without power. I would deeply appreciate any help y'all can give me. I know she's a project RV and has issues but hey, who doesn't =)
Thanks,
Merry and Ethyl
__________________

__________________
MerryK is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-14-2012, 05:48 PM   #2
Senior Member
 
wb7auk's Avatar
 
National RV Owners Club
Join Date: Feb 2012
Location: Spokane Valley, Wa
Posts: 1,987
Some where in the MH there is a electric panel for 110 AC check the main breakers sounds like they are off.
__________________

__________________
wb7auk is offline   Reply With Quote
Old 03-14-2012, 05:53 PM   #3
Senior Member
 
Join Date: Nov 2010
Location: hanson ma
Posts: 206
no power

it sounds to me like you have no 12v power and just about every thing needs 12v to work like fridge the controls work on 12v so will functon while boondocking might try connecting house battery to a good battery with jumper cables lee
__________________
hometool is offline   Reply With Quote
Old 03-14-2012, 06:00 PM   #4
Member
 
Join Date: Feb 2012
Posts: 34
they are not off and now I have power to an electrical plug in in the rv but only to that one. Does the inverter HAVE to be running?
Thanks,
Merry
__________________
MerryK is offline   Reply With Quote
Old 03-14-2012, 06:11 PM   #5
Member
 
Join Date: Feb 2012
Posts: 34
The fridge is a replacement and is just a regular tiny thing that plugs into 110. I discovered today that the lights are 12v. which is fine. I'm running an extension cord so I use a lamp while I'm out in Ethyl. My main concern is the A/C. I live in Florida and it's getting hot already =) Ethyl is like an oven.
__________________
MerryK is offline   Reply With Quote
Old 03-14-2012, 06:32 PM   #6
Registered User


 
Monaco Owners Club
Join Date: May 2009
Posts: 3,198
Didn't most of your (12v) stuff used to work?

You need to charge those batteries, one way or another. Check the water in em too.
__________________
JimM68 is offline   Reply With Quote
Old 03-14-2012, 07:40 PM   #7
Member
 
Join Date: Feb 2012
Posts: 34
Ethyl does have electricity but it's all wired screwy and backwards. Only one outlet in the RV works. and we got the a/c working too. Might need a freon charge but it's working. Thanks for all your help.
Merry & Ethyl
__________________
MerryK is offline   Reply With Quote
Old 03-14-2012, 07:43 PM   #8
Member
 
Join Date: Feb 2012
Posts: 34
will do Jim. but it's raining waterfalls out there right now.
__________________
MerryK is offline   Reply With Quote
Old 03-14-2012, 10:13 PM   #9
Senior Member
 
QuietWater's Avatar
 
Join Date: Oct 2009
Location: West Central MO
Posts: 328
My 84 Holiday Rambler Imperial has an inverter switch behind the driver's seat. It sounds to me like you have it switched on to the inverter side instead of the shore power side. If the batteries are not charged and you are on shore power then when it is switched up to the inverter, only one outlet will work and one of the air conditioners will work. If it is switched down to the shorepower then everything should work. Yours might be different but that is how mine works.


__________________
1984 Holiday Rambler Imperial
QuietWater is offline   Reply With Quote
Old 03-15-2012, 07:46 PM   #10
Junior Member
 
Join Date: Mar 2012
Posts: 19
power

I dont have that switch. I have to open up my panel(i have 2) and shut off a main breaker.
__________________
nepagearjamm is offline   Reply With Quote
Old 03-16-2012, 07:24 PM   #11
Member
 
Join Date: Feb 2012
Posts: 34
found the main breaker panel in a cupboard I hadn't looked in yet (under the closets). I figure I'll have an RV repair person or somebody who knows more about RV's than the people who have checked Ethyl out so far. The A/c works (about freezes me out), got electric on one side of the RV (two outlets). Figure I'll send out to Holiday Rambler and see if I can get the spec sheets and wiring diagrams from them, it will be worth the money I think.
I really enjoy living in an RV, it's all self contained. Ordered my white hose from wal-mart ($26.00 with shipping, costs more than shipping to drive to the nearest WM). Next thing to find out is who I can get to dump the tanks when they need it. Not too worried about that yet though. I haven't used enough water in any form out here yet.
__________________

__________________
MerryK is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lippert Landing Gear Problems Alberthal 5th Wheel Discussion 8 09-16-2013 05:16 PM
Has anyone used Blue Beacon Truck wash for TT? jlee815 Travel Trailer Discussion 3 04-05-2012 09:42 PM
Discovery inverter problems Ramzfan Fleetwood Products Owner's Forum 12 03-18-2012 01:21 PM
Has anyone have to have both sides Upper and lower ball joints replaced bassoneman iRV2.com General Discussion 7 03-15-2012 10:27 AM
Satellite input for hr endeavor dennis46c Monaco Owner's Forum 4 03-14-2012 11:28 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:31 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.